remove ligo-common requirement for python3

Python 3 supports implicit namespace packages, meaning a base package for the `ligo` namespace is not required
14 jobs for python3-no-ligo-common in 90 minutes and 7 seconds (queued for 35 minutes and 12 seconds)
Status Job ID Name Coverage
  Build
passed #1280550
build:debian:buster

00:03:08

passed #1280549
build:debian:stretch

00:02:53

passed #1280548
build:el7

00:20:20

passed #1280547
build:tarball

00:02:21

 
  Test
passed #1280555
docs

00:00:46

passed #1280556
syntax

00:12:18

passed #1280551
test:python2.7

00:14:04

passed #1280552
test:python3.6

00:14:47

passed #1280553
test:python3.7

00:00:29

passed #1280554
test:python3.8

00:14:11

 
  Integration
failed #1280557
integration:python2.7

00:14:01

failed #1280558
integration:python3.6

00:14:23

failed #1280559
integration:python3.7

00:13:50

failed #1280560
integration:python3.8

00:12:41

 
Name Stage Failure
failed
integration:python3.7 Integration
Setting up bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u3) ...
Setting up krb5-config (2.6) ...
Setting up krb5-user (1.17-3+deb10u1) ...
Processing triggers for libc-bin (2.28-10) ...
$ echo "${ROBOT_KEYTAB}" | base64 -d | install -m 0600 /dev/stdin keytab
$ ROBOT_PRINCIPAL=$(klist -k keytab | head -n 4 | tail -n 1 | sed -E 's/^.* +//')
klist: Unsupported key table format version number while starting keytab scan
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
integration:python2.7 Integration
Setting up libkrb5-dev:amd64 (1.17-3+deb10u1) ...
Setting up krb5-config (2.6) ...
Setting up krb5-user (1.17-3+deb10u1) ...
Processing triggers for libc-bin (2.28-10) ...
$ echo "${ROBOT_KEYTAB}" | base64 -d | install -m 0600 /dev/stdin keytab
$ ROBOT_PRINCIPAL=$(klist -k keytab | head -n 4 | tail -n 1 | sed -E 's/^.* +//')
klist: Unsupported key table format version number while starting keytab scan
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
integration:python3.8 Integration
Setting up bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u3) ...
Setting up krb5-config (2.6) ...
Setting up krb5-user (1.17-3+deb10u1) ...
Processing triggers for libc-bin (2.28-10) ...
$ echo "${ROBOT_KEYTAB}" | base64 -d | install -m 0600 /dev/stdin keytab
$ ROBOT_PRINCIPAL=$(klist -k keytab | head -n 4 | tail -n 1 | sed -E 's/^.* +//')
klist: Unsupported key table format version number while starting keytab scan
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
integration:python3.6 Integration
Setting up bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u3) ...
Setting up krb5-config (2.6) ...
Setting up krb5-user (1.17-3+deb10u1) ...
Processing triggers for libc-bin (2.28-10) ...
$ echo "${ROBOT_KEYTAB}" | base64 -d | install -m 0600 /dev/stdin keytab
$ ROBOT_PRINCIPAL=$(klist -k keytab | head -n 4 | tail -n 1 | sed -E 's/^.* +//')
klist: Unsupported key table format version number while starting keytab scan
Cleaning up file based variables
ERROR: Job failed: exit code 1