Commit 74c08ba0 authored by Leo Pound Singer's avatar Leo Pound Singer Committed by Kipp Cannon

Add dependency on python-ligo-lw

parent b4f9e035
......@@ -91,6 +91,7 @@ outputs:
- gsl
- hdf5 # [linux]
- {{ pin_subpackage('lal', exact=True) }}
- python-ligo-lw
- ligo-segments
- lscsoft-glue >=@MIN_GLUE_VERSION@
- mkl # [fft_impl == "mkl"]
......
......@@ -19,6 +19,7 @@ Build-Depends: bc,
python-dateutil,
python-freezegun,
python-glue (>= @MIN_GLUE_VERSION@),
python-ligo-lw,
python-ligo-segments,
python-mock,
python-numpy (>= @MIN_NUMPY_VERSION@),
......@@ -30,6 +31,7 @@ Build-Depends: bc,
python3-dateutil,
python3-freezegun,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-ligo-lw,
python3-ligo-segments,
python3-numpy (>= @MIN_NUMPY_VERSION@),
python3-pytest,
......@@ -83,6 +85,7 @@ Architecture: any
Depends: ${misc:Depends},
${python:Depends},
${shlibs:Depends},
python-ligo-lw,
python-ligo-segments,
python-glue (>= @MIN_GLUE_VERSION@),
python-scipy,
......@@ -111,6 +114,7 @@ Architecture: any
Depends: ${misc:Depends},
${python3:Depends},
${shlibs:Depends},
python3-ligo-lw,
python3-ligo-segments,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-scipy,
......
......@@ -43,6 +43,7 @@ BuildRequires: python-devel
BuildRequires: python2-dateutil
BuildRequires: python2-freezegun
BuildRequires: python2-glue >= @MIN_GLUE_VERSION@
BuildRequires: python2-ligo-lw
BuildRequires: python2-ligo-segments
BuildRequires: python2-mock
BuildRequires: python2-numpy >= @MIN_NUMPY_VERSION@
......@@ -60,6 +61,7 @@ BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-dateutil
BuildRequires: python%{python3_pkgversion}-freezegun
BuildRequires: python%{python3_pkgversion}-glue >= @MIN_GLUE_VERSION@
BuildRequires: python%{python3_pkgversion}-ligo-lw
BuildRequires: python%{python3_pkgversion}-ligo-segments
BuildRequires: python%{python3_pkgversion}-numpy >= @MIN_NUMPY_VERSION@
BuildRequires: python%{python3_pkgversion}-pytest
......@@ -104,6 +106,7 @@ Requires: %{name} = %{version}
Requires: python
Requires: python2-dateutil
Requires: python2-glue >= @MIN_GLUE_VERSION@
Requires: python2-ligo-lw
Requires: python2-ligo-segments
Requires: python2-numpy >= @MIN_NUMPY_VERSION@
Requires: python2-scipy
......@@ -129,6 +132,7 @@ Requires: %{name} = %{version}
Requires: python%{python3_pkgversion}
Requires: python%{python3_pkgversion}-dateutil
Requires: python%{python3_pkgversion}-glue >= @MIN_GLUE_VERSION@
Requires: python%{python3_pkgversion}-ligo-lw
Requires: python%{python3_pkgversion}-ligo-segments
Requires: python%{python3_pkgversion}-numpy >= @MIN_NUMPY_VERSION@
Requires: python%{python3_pkgversion}-scipy
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment