Commit fe91c9a0 authored by Sean Leavey's avatar Sean Leavey
Browse files

Pin build numpy version to runtime version

parent dfa2912f
[build-system]
requires = ["setuptools", "wheel", "setuptools_scm[toml]", "Cython>=0.29", "numpy >= 1.20.0"]
requires = [
"setuptools",
"wheel",
"setuptools_scm[toml]",
"Cython",
"numpy == 1.20.3", # Should match that in setup.cfg install_requires.
]
build-backend = "setuptools.build_meta"
[tool.setuptools_scm]
......
......@@ -36,7 +36,7 @@ install_requires =
# for more information.
# Pin these to specific packages so updates don't break Finesse in the wild.
# Periodically update these to newer versions where possible.
numpy==1.20.3
numpy==1.20.3 # Should match that in pyproject.toml build-system requirements.
scipy==1.6.3
matplotlib==3.4.2
networkx==2.5.1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment