Commit 13b21f6e authored by Phil Jones's avatar Phil Jones

Fix broken imports in SciPy 1.3

A couple of imports have been removed from `scipy.misc` in version 1.3,
and must be obtained from `scipy.special` instead. This requires at
least SciPy 0.14.0.
parent ab849208
...@@ -5,7 +5,7 @@ channels: ...@@ -5,7 +5,7 @@ channels:
dependencies: dependencies:
- numpy>=1.12 - numpy>=1.12
- flask>=0.10.1 - flask>=0.10.1
- scipy - scipy>=0.14.0
- six - six
- h5py - h5py
- pandas - pandas
......
import numpy as np import numpy as np
from scipy.misc import factorial as fac from scipy.special import factorial as fac
from six.moves import xrange from six.moves import xrange
import math import math
......
...@@ -8,9 +8,8 @@ from scipy.integrate import dblquad ...@@ -8,9 +8,8 @@ from scipy.integrate import dblquad
from pykat.optics.romhom import ROMWeights from pykat.optics.romhom import ROMWeights
from math import factorial from math import factorial
from pykat.math.hermite import hermite from pykat.math.hermite import hermite
from scipy.misc import comb
from scipy.integrate import newton_cotes from scipy.integrate import newton_cotes
from scipy.special import gammainc from scipy.special import comb, gammainc
from pykat.math import newton_weights from pykat.math import newton_weights
import time import time
......
numpy >= 1.12 numpy >= 1.12
flask >= 0.10.1 flask >= 0.10.1
scipy scipy >= 0.14.0
six six
h5py h5py
pandas pandas
matplotlib matplotlib
tabulate tabulate
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment