Commit 0c99de55 authored by Sean Leavey's avatar Sean Leavey

Remove import exception: graphviz python module is small enough to bundle with...

Remove import exception: graphviz python module is small enough to bundle with Pykat, and it already tells the user if graphviz is not installed on the system path
parent 54764895
......@@ -5,12 +5,7 @@ Based on node_graph project by Sebastian Steinlechner: https://github.com/sestei
import tempfile
from ...components import laser, space
from ...exceptions import BasePyKatException
try:
from graphviz import Digraph
except ImportError:
raise BasePyKatException("The 'graphviz' Python library is required to generate node graphs.")
from graphviz import Digraph
class NodeGraph(object):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment