Commit 4d231288 authored by Patrick Godwin's avatar Patrick Godwin

setup.py: add dependencies for install_requires, classifiers

parent 852dff91
Pipeline #82468 failed with stages
in 2 minutes and 1 second
import os
from setuptools import setup
install_requires = [
'bottle >= 0.12',
'h5py >= 2.3',
'ligo-common >= 1.0',
'numpy >= 1.7',
'PyYAML >= 3.10',
'urllib3 >= 1.10',
'python-dateutil',
]
setup(
name = 'ligo-scald',
description = 'SCalable Analytics for Ligo Data',
......@@ -18,9 +28,30 @@ setup(
'templates': ['*'],
},
entry_points={
entry_points = {
'console_scripts': [
'scald = ligo.scald.__main__:main',
],
},
install_requires = install_requires,
classifiers = [
'Development Status :: 4 - Beta',
'Programming Language :: Python',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Intended Audience :: Science/Research',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: Developers',
'Natural Language :: English',
'Topic :: Scientific/Engineering',
'Topic :: Scientific/Engineering :: Astronomy',
'Topic :: Scientific/Engineering :: Physics',
'Operating System :: POSIX',
'Operating System :: Unix',
'Operating System :: MacOS',
'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
],
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment