Commit d041fa98 authored by Duncan Macleod's avatar Duncan Macleod

more fixes

- can only build on buster because we need flask-1.0.0
parent 8c955df2
Pipeline #60357 failed with stages
in 2 minutes and 33 seconds
......@@ -74,9 +74,10 @@ dist:tarball:
- popd
- mv -v {python,python3}-gwdatafind-server_*.deb gwdatafind-server_*.{buildinfo,changes} dist/${DIST_NAME}/
build:debian:stretch:
build:debian:buster:
<<: *build-debian
image: ligo/base:stretch
image: ligo/base:buster
allow_failure: true
# -- test -------------------
......
......@@ -26,7 +26,7 @@ def find_version(path):
install_requires = [
"setuptools",
"flask",
"flask >= 1.0.0",
"configobj",
"ligo-segments",
]
......@@ -35,7 +35,7 @@ install_requires = [
setup(
# metadata
name="gwdatafind_server",
name="gwdatafind-server",
version=find_version(Path("gwdatafind_server") / "__init__.py"),
author="Duncan Macleod",
author_email="duncan.macleod@ligo.org",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment