Commit 1024ccc8 authored by Jameson Graef Rollins's avatar Jameson Graef Rollins

setup.py cleanup

fix name, version and included files
parent f84053c9
include LICENSE include CONTRIBUTIONS.md
include README.md
include DISTRIBUTION-README.md
include MANIFEST.in
include setup.cfg include setup.cfg
include setup.py
include tox.ini include tox.ini
include CONTRIBUTIONS.md
recursive-include *.py recursive-include gwinc *.yaml
recursive-include gwinc *.py
recursive-include matlab *.m recursive-include matlab *.m
recursive-include docs * recursive-include docs *
#!/usr/bin/env python #!/usr/bin/env python3
# -*- coding: utf-8 -*- # -*- coding: utf-8 -*-
from __future__ import division, print_function, unicode_literals
from setuptools import find_packages, setup from setuptools import find_packages, setup
version = '0.9.5' version = '0.1'
setup_args = dict( setup_args = dict(
name = 'GWINC', name = 'gwinc',
version = version, version = version,
url = 'https://git.ligo.org/gwinc/pygwinc', url = 'https://git.ligo.org/gwinc/pygwinc',
author = 'LIGO Laboratory', author = 'LIGO Laboratory',
author_email = 'jrollins@ligo.caltech.edu ', author_email = 'jrollins@ligo.caltech.edu ',
description = "Gravitation Wave Interferometer Noise Calculator", description = "Gravitation Wave Interferometer Noise Calculator",
license = 'Copyright 2017 LIGO Laboratory', license = 'Copyright 2018 LIGO Laboratory',
install_requires = [ keywords = 'Noise, LIGO, Gravitational Wave,',
'numpy', classifiers = [
'scipy',
'matplotlib',
],
packages = find_packages(
exclude = ['docs',],
),
include_package_data = True,
zip_safe = True,
keywords = 'Noise, LIGO, Gravitational Wave,',
classifiers=[
'Topic :: Scientific/Engineering', 'Topic :: Scientific/Engineering',
'Operating System :: OS Independent', 'Operating System :: OS Independent',
'Programming Language :: Python', 'Programming Language :: Python',
...@@ -37,6 +26,19 @@ setup_args = dict( ...@@ -37,6 +26,19 @@ setup_args = dict(
'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.6',
], ],
install_requires = [
'numpy',
'scipy',
'matplotlib',
],
packages = find_packages(
exclude = ['docs',],
),
include_package_data = True,
zip_safe = True,
) )
if __name__ == "__main__": if __name__ == "__main__":
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment