snglcoinc.CoincRates: remove stone-throwing code, require scipy 0.19

- set minimum required scipy version at 0.19 for lalburst
- remove CoincRates stone-throwing code from .__init__() and require scipy's wrapping of qhull's half-space intersection.
- also rewrite the documentation
39 jobs for lalburst_scipy_0_19 in 90 minutes and 2 seconds (queued for 11 seconds)