Commit 2554f944 authored by Tanner Prestegard's avatar Tanner Prestegard

Update as much of the CI process as possible to use Python 3.7

parent 571cc87c
......@@ -14,7 +14,7 @@ stages:
build:tarball:
<<: *build
image: python:3.6
image: python:3.7-slim
script:
- python setup.py sdist bdist_wheel
......@@ -103,7 +103,7 @@ test:python3.7:
# Although we don't host the docs on Gitlab Pages,
# we still want to check that they build properly.
docs:
image: python:3.6-slim
image: python:3.7-slim
script:
- apt-get update
- apt-get install build-essential git -y
......@@ -113,7 +113,7 @@ docs:
# -- linting ----------------
syntax:
image: python:3.6-slim
image: python:3.7-slim
script:
- pip install -r requirements-dev.txt
- flake8 *.py ligo/ --count
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment