Commit 326bc3ae authored by Tanner Prestegard's avatar Tanner Prestegard

Require some update in updateSuperevent

Require that some parameter is set to be upgraded for
updateSuperevent(), otherwise fail.
parent ec8ec663
......@@ -742,6 +742,10 @@ class GraceDb(GsiRest):
>>> r.status
200
"""
# Make sure that at least one parameter is provided
if not (t_start or t_0 or t_end or preferred_event):
raise ValueError('Provide at least one of t_start, t_0, t_end, or '
'preferred_event')
request_body = {}
if t_start:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment