WIP: try numpy 1.20.0

59 jobs for try-latest-numpy in 132 minutes and 21 seconds (queued for 12 seconds)
latest
Status Job ID Name Coverage
  .Pre
passed #1175189
make-dist

00:06:43

passed #1175190
make-dist:lal

00:01:03

 
  Lal
passed #1175193
lal:conda:fftw

00:38:43

passed #1175194
lal:conda:mkl

00:34:46

passed #1175192
lal:deb

00:14:54

passed #1175191
lal:rpm

00:15:00

 
  Lal Frame
passed #1175197
lalframe:conda

00:30:13

passed #1175196
lalframe:deb

00:05:44

passed #1175195
lalframe:rpm

00:05:49

 
  Lal Meta Io
passed #1175200
lalmetaio:conda

00:28:04

passed #1175199
lalmetaio:deb

00:06:38

passed #1175198
lalmetaio:rpm

00:05:52

 
  Lal Simulation
passed #1175203
lalsimulation:conda

00:32:25

passed #1175202
lalsimulation:deb

00:10:15

passed #1175201
lalsimulation:rpm

00:13:52

 
  Lal Burst
failed #1175206
lalburst:conda

00:25:21

passed #1175205
lalburst:deb

00:16:58

passed #1175204
lalburst:rpm

00:18:48

 
  Lal Inspiral
skipped #1175209
lalinspiral:conda
passed #1175208
lalinspiral:deb

00:12:46

passed #1175207
lalinspiral:rpm

00:14:14

 
  Lal Pulsar
passed #1175212
lalpulsar:conda

00:37:36

passed #1175211
lalpulsar:deb

00:12:14

passed #1175210
lalpulsar:rpm

00:11:38

 
  Lal Inference
skipped #1175215
lalinference:conda
passed #1175214
lalinference:deb

00:11:53

passed #1175213
lalinference:rpm

00:11:14

 
  Lal Apps
skipped #1175218
lalapps:conda
passed #1175217
lalapps:deb

00:12:01

passed #1175216
lalapps:rpm

00:10:17

 
  Lint
passed #1175220
lint:coala

00:00:54

passed #1175219
lint:python

00:00:53

 
  Integration Tests
passed #1175223
coverage

00:44:48

19.18%
passed #1175221
lalinference_testjob

00:18:04

passed #1175222
top-level

00:45:54

 
  Compiler Tests
passed #1175224
clang:10

00:31:37

passed #1175225
clang:11

00:33:38

passed #1175226
clang:dev

00:34:47

passed #1175231
cuda

00:16:34

passed #1175230
gcc:10

00:28:13

passed #1175227
gcc:7

00:28:12

passed #1175228
gcc:8

00:37:31

passed #1175229
gcc:9

00:28:06

 
  Platform Tests
failed #1175235
allowed to fail
platform:conda:linux

00:12:44

passed #1175232
platform:debian:buster

00:33:27

passed #1175233
macos_highsierra
platform:macos:highsierra

00:23:08

passed #1175234
macos_sierra
platform:macos:sierra

00:24:56

 
  Upgrade Tests
skipped #1175238
upgrade:conda:linux
passed #1175237
upgrade:debian:stretch

00:04:43

passed #1175236
upgrade:rpm:el7

00:05:29

 
  Docker
passed #1175239
docker:nightly:el7

00:07:44

passed #1175240
docker:nightly:stretch

00:07:31

 
  Wheels
failed #1175244
macos_sierra
wheel:cp36-cp36m-macosx

00:00:28

failed #1175241
wheel:cp36-cp36m-manylinux2014

00:12:31

failed #1175245
macos_sierra
wheel:cp37-cp37m-macosx

00:17:39

failed #1175242
wheel:cp37-cp37m-manylinux2014

00:12:34

failed #1175246
macos_sierra
wheel:cp38-cp38-macosx

00:17:50

failed #1175243
wheel:cp38-cp38-manylinux2014

00:14:10

 
  Deploy
skipped #1175247
deploy:wheel
 
Name Stage Failure
failed
lalburst:conda Lal Burst
WARNING: conda/bld/lalburst-*/work/*/*/*/*/test-suite.log: no matching files 
lalburst/lalburst-feedstock/: found 134 matching files and directories

Uploading artifacts as "archive" to coordinator... ok
id=1175206 responseStatus=201 Created token=WUpV7PfB
Uploading artifacts...
WARNING: conda/bld/lalburst[-_]*/work/_build*/test/python/junit*.xml: syntax error in pattern
WARNING: conda/bld/lalburst[-_]*/test_tmp/junit*.xml: syntax error in pattern
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
wheel:cp38-cp38-manylinux2014 Wheels
    Running setup.py install for lscsoft-glue: started
Running setup.py install for lscsoft-glue: finished with status 'done'
Successfully installed cffi-1.14.4 cryptography-3.3.1 cycler-0.10.0 kiwisolver-1.3.1 lalsuite-6.81.1.dev20210201 ligo-segments-1.3.0 lscsoft-glue-2.0.0 matplotlib-3.3.4 numpy-1.20.0 pillow-8.1.0 pyOpenSSL-20.0.1 pycparser-2.20 pyparsing-2.4.7 python-dateutil-2.8.1 scipy-1.6.0 six-1.15.0
++ echo '
$ python -c '\''import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'\'''
$ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
++ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
/usr/bin/bash: line 154: 23622 Segmentation fault python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
wheel:cp37-cp37m-manylinux2014 Wheels
    Running setup.py install for lscsoft-glue: started
Running setup.py install for lscsoft-glue: finished with status 'done'
Successfully installed cffi-1.14.4 cryptography-3.3.1 cycler-0.10.0 kiwisolver-1.3.1 lalsuite-6.81.1.dev20210201 ligo-segments-1.3.0 lscsoft-glue-2.0.0 matplotlib-3.3.4 numpy-1.20.0 pillow-8.1.0 pyOpenSSL-20.0.1 pycparser-2.20 pyparsing-2.4.7 python-dateutil-2.8.1 scipy-1.6.0 six-1.15.0
$ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
++ echo '
$ python -c '\''import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'\'''
++ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
/usr/bin/bash: line 154: 23628 Segmentation fault python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
wheel:cp36-cp36m-manylinux2014 Wheels
  Downloading importlib_resources-5.1.0-py3-none-any.whl (24 kB)
Collecting scipy
Downloading scipy-1.5.4-cp36-cp36m-manylinux1_x86_64.whl (25.9 MB)
Collecting python-dateutil
Downloading python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)
ERROR: Could not find a version that satisfies the requirement numpy>=1.20.0 (from lalsuite)
ERROR: No matching distribution found for numpy>=1.20.0
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
platform:conda:linux Platform Tests
make[1]: Leaving directory '/builds/leo-singer/lalsuite'
make[1]: *** [Makefile:416: check-recursive] Error 1
make: *** [Makefile:690: check] Error 2
Uploading artifacts for failed job
Uploading artifacts...
WARNING: */test/python/junit*.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
wheel:cp38-cp38-macosx Wheels
Successfully installed cffi-1.14.4 cryptography-3.3.1 cycler-0.10.0 kiwisolver-1.3.1 lalsuite-6.81.1.dev20210201 ligo-segments-1.3.0 lscsoft-glue-2.0.0 matplotlib-3.3.4 numpy-1.20.0 pillow-8.1.0 pyOpenSSL-20.0.1 pycparser-2.20 pyparsing-2.4.7 python-dateutil-2.8.1 scipy-1.6.0 six-1.15.0
WARNING: You are using pip version 20.2.3; however, version 21.0 is available.
You should consider upgrading via the '/Users/gitlab/builds/409cdfe8/0/leo-singer/lalsuite/test/bin/python -m pip install --upgrade pip' command.
++ echo '
$ python -c '\''import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'\'''
$ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
++ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
bash: line 158: 96803 Segmentation fault: 11 python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
Cleaning up file based variables
ERROR: Job failed: exit status 1
failed
wheel:cp37-cp37m-macosx Wheels
Successfully installed cffi-1.14.4 cryptography-3.3.1 cycler-0.10.0 kiwisolver-1.3.1 lalsuite-6.81.1.dev20210201 ligo-segments-1.3.0 lscsoft-glue-2.0.0 matplotlib-3.3.4 numpy-1.20.0 pillow-8.1.0 pyOpenSSL-20.0.1 pycparser-2.20 pyparsing-2.4.7 python-dateutil-2.8.1 scipy-1.6.0 six-1.15.0
WARNING: You are using pip version 20.1.1; however, version 21.0 is available.
You should consider upgrading via the '/Users/gitlab/builds/62144ec5/0/leo-singer/lalsuite/test/bin/python -m pip install --upgrade pip' command.
++ echo '
$ python -c '\''import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'\'''
$ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
++ python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
bash: line 158: 46961 Segmentation fault: 11 python -c 'import lal, lalframe, lalmetaio, lalsimulation; series = lal.CreateREAL8FrequencySeries("psd", 0, 0, 1, None, 4096); lalsimulation.SimNoisePSDaLIGOAPlusDesignSensitivityT1800042(series, 10)'
Cleaning up file based variables
ERROR: Job failed: exit status 1
failed
wheel:cp36-cp36m-macosx Wheels
Switched to a new branch 'fix-duplicate-libs'
Branch 'fix-duplicate-libs' set up to track remote branch 'fix-duplicate-libs' from 'origin'.
Collecting numpy>=1.20.0
Could not find a version that satisfies the requirement numpy>=1.20.0 (from versions: 1.3.0, 1.4.1, 1.5.0, 1.5.1, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1, 1.8.2, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.10.0.post2, 1.10.1, 1.10.2, 1.10.4, 1.11.0b3, 1.11.0rc1, 1.11.0rc2, 1.11.0, 1.11.1rc1, 1.11.1, 1.11.2rc1, 1.11.2, 1.11.3, 1.12.0b1, 1.12.0rc1, 1.12.0rc2, 1.12.0, 1.12.1rc1, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0, 1.13.1, 1.13.3, 1.14.0rc1, 1.14.0, 1.14.1, 1.14.2, 1.14.3, 1.14.4, 1.14.5, 1.14.6, 1.15.0rc1, 1.15.0rc2, 1.15.0, 1.15.1, 1.15.2, 1.15.3, 1.15.4, 1.16.0rc1, 1.16.0rc2, 1.16.0, 1.16.1, 1.16.2, 1.16.3, 1.16.4, 1.16.5, 1.16.6, 1.17.0rc1, 1.17.0rc2, 1.17.0, 1.17.1, 1.17.2, 1.17.3, 1.17.4, 1.17.5, 1.18.0rc1, 1.18.0, 1.18.1, 1.18.2, 1.18.3, 1.18.4, 1.18.5, 1.19.0rc1, 1.19.0rc2, 1.19.0, 1.19.1, 1.19.2, 1.19.3, 1.19.4, 1.19.5)
No matching distribution found for numpy>=1.20.0
You are using pip version 18.1, however version 21.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Cleaning up file based variables
ERROR: Job failed: exit status 1