WIP: Update from Astropy package template

astropy_helpers is now gone.
15 jobs for no-astropy-helpers in 1 minute and 35 seconds (queued for 2 seconds)
latest
Status Job ID Name Coverage
  Dist
passed #633127
dependencies/python3.6

00:00:30

passed #633128
dependencies/python3.7

00:00:29

passed #633120
sdist

00:00:32

passed #633124
macos_sierra
wheel/cp36-cp36m-macosx

00:00:30

passed #633121
wheel/cp36-cp36m-manylinux2014

00:00:44

passed #633125
macos_sierra
wheel/cp37-cp37m-macosx

00:00:32

passed #633122
wheel/cp37-cp37m-manylinux2014

00:00:43

passed #633126
macos_sierra
wheel/cp38-cp38-macosx

00:00:31

passed #633123
wheel/cp38-cp38-manylinux2014

00:00:45

 
  Test
failed #633130
docs

00:00:17

passed #633129
lint

00:00:22

failed #633133
test/coverage

00:00:17

failed #633131
test/python3.6

00:00:29

failed #633132
test/python3.7

00:00:27

 
  Deploy
skipped #633134
sccb
 
Name Stage Failure
failed
test/python3.6 Test
WARNING: AstropyDeprecationWarning: The astropy.tests.plugins.display plugin has been deprecated. See the pytest-astropy-header documentation for information on migrating to using pytest-astropy-header to customize the pytest header. [astropy.tests.plugins.display]
ImportError while loading conftest '/usr/local/lib/python3.6/site-packages/ligo/skymap/conftest.py'.
/usr/local/lib/python3.6/site-packages/ligo/skymap/conftest.py:30: in <module>
from .version import version, astropy_helpers_version
E ImportError: cannot import name 'astropy_helpers_version'
Running after script...
$ cd "${CI_PROJECT_DIR}"
$ rm -rf "${WORKING_DIRECTORY}"
ERROR: Job failed: exit code 1
failed
test/python3.7 Test
WARNING: AstropyDeprecationWarning: The astropy.tests.plugins.display plugin has been deprecated. See the pytest-astropy-header documentation for information on migrating to using pytest-astropy-header to customize the pytest header. [astropy.tests.plugins.display]
ImportError while loading conftest '/usr/local/lib/python3.7/site-packages/ligo/skymap/conftest.py'.
/usr/local/lib/python3.7/site-packages/ligo/skymap/conftest.py:30: in <module>
from .version import version, astropy_helpers_version
E ImportError: cannot import name 'astropy_helpers_version' from 'skymap.version' (/usr/local/lib/python3.7/site-packages/ligo/skymap/version.py)
Running after script...
$ cd "${CI_PROJECT_DIR}"
$ rm -rf "${WORKING_DIRECTORY}"
ERROR: Job failed: exit code 1
failed
test/coverage Test
    from extension_helpers import add_openmp_flags_if_available, pkg_config
ModuleNotFoundError: No module named 'extension_helpers'
Running after script...
$ cd "${CI_PROJECT_DIR}"
$ rm -rf "${WORKING_DIRECTORY}"
Uploading artifacts...
WARNING: junit.xml: no matching files
ERROR: No files to upload
ERROR: Job failed: exit code 1
failed
docs Test
$ python setup.py build_docs
Traceback (most recent call last):
File "setup.py", line 14, in <module>
from extension_helpers import add_openmp_flags_if_available, pkg_config
ModuleNotFoundError: No module named 'extension_helpers'
Running after script...
$ cd "${CI_PROJECT_DIR}"
$ rm -rf "${WORKING_DIRECTORY}"
ERROR: Job failed: exit code 1