Commit 2dde3303 authored by Gregory Ashton's avatar Gregory Ashton

Merge branch '240-make-bilby-into-a-conda-package' into 'master'

Resolve "Make Bilby into a conda package"

Closes #240

See merge request !330
parents d3961f67 d5ad0dd2
Pipeline #44158 passed with stages
in 13 minutes and 45 seconds
......@@ -31,7 +31,8 @@ sys.path.insert(0, os.path.abspath('../bilby/'))
# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
# ones.
extensions = ['sphinx.ext.autodoc', 'sphinx.ext.mathjax', 'numpydoc',
'nbsphinx', 'sphinx.ext.autosummary', 'sphinx.ext.autosectionlabel']
'nbsphinx', 'sphinx.ext.autosummary',
'sphinx.ext.autosectionlabel', 'sphinx_tabs.tabs']
# Add any paths that contain templates here, relative to this directory.
templates_path = ['_templates']
......
......@@ -2,23 +2,51 @@
Installation
============
The lastest stable release of Bilby can be `pip-installed
<https://pypi.org/project/BILBY/>`_ from
.. tabs::
.. code-block:: console
.. tab:: Pip
.. code-block:: console
$ pip install bilby
Supported python versions: 2.7, 3.5+.
.. tab:: Conda
.. code-block:: console
$ conda install -c conda-forge bilby
Supported python versions: 2.7, 3.5+.
This will install all requirements for running :code:`bilby` for general
inference problems, including our default sampler `dynesty
<https://dynesty.readthedocs.io/en/latest/>`_. Other samplers will need to be
installed via pip or the appropriate means.
To install the requirements for running :code:`bilby.gw` for gravitational
wave inference, please additionally run the following commands.
.. tabs::
.. tab:: Pip
.. code-block:: console
$ pip install gwpy lalsuite
.. tab:: Conda
.. code-block:: console
$ pip install bilby
$ conda install -c conda-forge gwpy python-lalsimulation
This will install our default sampler `dynesty
<https://dynesty.readthedocs.io/en/latest/>`_, other samplers will need to be
installed via pip or the appropriate means. If you plan to contribute to the
development, or simply would like the latest code, see the instructions below
for installing from source.
Install bilby from source
-------------------------
:code:`bilby` is developed and tested with both Python 2.7+ and Python 3+. In the
:code:`bilby` is developed and tested with both Python 2.7+ and Python 3.7+. In the
following, we assume you have a working python installation, `python pip
<https://packaging.python.org/tutorials/installing-packages/#use-pip-for-installing)>`_,
and `git <https://git-scm.com/>`_. See :ref:`installing-python` for our
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment