remove ligo-common requirement for python3

Python 3 supports implicit namespace packages, meaning a base package for the `ligo` namespace is not required
14 jobs for master in 98 minutes and 15 seconds (queued for 94 minutes and 12 seconds)
latest
Status Job ID Name Coverage
  Build
passed #1280870
build:debian:buster

00:03:57

passed #1280869
build:debian:stretch

00:01:07

passed #1280868
build:el7

00:29:09

passed #1280867
build:tarball

00:02:26

 
  Test
passed #1280875
docs

00:00:46

passed #1280876
syntax

00:15:18

passed #1280871
test:python2.7

00:15:24

75.0%
passed #1280872
test:python3.6

00:00:30

75.0%
passed #1280873
test:python3.7

00:13:35

75.0%
passed #1280874
test:python3.8

00:15:25

75.0%
 
  Integration
passed #1280877
integration:python2.7

00:15:21

passed #1280878
integration:python3.6

00:17:58

passed #1280879
integration:python3.7

00:16:08

passed #1280880
integration:python3.8

00:04:10