Pin pluggy version

Recent release of pluggy (0.10.0), which is a dependency of pytest,
does not properly declare its dependency on importlib_metadata.
parent 3185633e
Pipeline #60919 passed with stages
in 4 minutes and 20 seconds