requirements.txt 1.29 KB
Newer Older
1
ConcurrentLogHandler==0.9.1
2
Django==1.11.23
3 4
django-debug-toolbar==1.9.1
django-extensions==2.0.5
5
django-guardian==1.4.9
6
django-model-utils==3.1.1
7
django-ses==0.8.10
8
django-silk==3.0.1
9
django-twilio==0.9.0
10
django-user-sessions==1.6.0
11
djangorestframework==3.9.0
12
djangorestframework-guardian==0.1.1
13
dnspython==1.15.0
14 15
flake8==3.5.0
html5lib==1.0.1
16
ipdb==0.10.2
17
ipython==5.5.0
18
lalsuite==6.53 # undocumented requirement for lscsoft-glue
19
ligo-lvalert==1.5.6
20
ligo-lvalert-overseer==0.1.3
21
lscsoft-glue==1.60.0
22
lxml==4.2.0
23
matplotlib==2.0.0
24
mock==2.0.0
25
mysqlclient==1.4.2
26 27
packaging==17.1
phonenumbers==8.8.11
28
python-ldap==3.1.0
29
python-memcached==1.59
30
scipy==1.2.1
31
sentry-sdk==0.7.10
32
service_identity==17.0.0
33
simplejson==3.15.0
34 35
Sphinx==1.7.0
twilio==6.10.3
36 37 38 39 40
# Do NOT upgrade pyparsing beyond 2.3.0 (even to 2.3.1) without carefully
# testing and modifying the search query code. There were a number of
# problematic API changes in 2.3.1 and beyond that will need to be handled
# appropriately.
pyparsing==2.3.0
41 42 43
pytest-cov==2.6.1
pytest-django==3.4.8
pytz==2018.9
44 45 46 47 48
# Fixed at old versions to prevent bugs:
# https://github.com/fritzy/SleekXMPP/issues/477
# https://github.com/etingof/pyasn1/issues/112
pyasn1==0.3.6
pyasn1-modules==0.1.5
49 50 51 52
# Installing future for gunicorn gthreads:
future==0.17.1
futures==3.2.0
gunicorn[gthread]==19.9.0