Commit 21769d43 authored by Kipp Cannon's avatar Kipp Cannon

gstlal,gstlal-burst,gstlal-inspiral: update python dep names

- lal-python --> python-lal
- lalinspiral-python --> python-lalinspiral
parent d71b6d6c
Pipeline #68433 passed with stages
in 25 minutes and 5 seconds
......@@ -7,40 +7,39 @@ Summary: GSTLAL Burst
License: GPL
Group: LSC Software/Data Analysis
Requires: gstlal-ugly >= @MIN_GSTLAL_UGLY_VERSION@
Requires: gstlal >= @MIN_GSTLAL_VERSION@
Requires: python >= @MIN_PYTHON_VERSION@
Requires: fftw >= 3
Requires: glue >= @MIN_GLUE_VERSION@
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: fftw >= 3
Requires: python-%{gstreamername}
Requires: gstlal >= @MIN_GSTLAL_VERSION@
Requires: gstlal-ugly >= @MIN_GSTLAL_UGLY_VERSION@
Requires: %{gstreamername} >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-base >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-good >= @MIN_GSTREAMER_VERSION@
Requires: gsl
Requires: h5py
Requires: numpy
Requires: scipy
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: numpy
Requires: orc >= @MIN_ORC_VERSION@
Requires: gsl
BuildRequires: pkgconfig >= 0.18.0
Requires: python >= @MIN_PYTHON_VERSION@
Requires: python-%{gstreamername}
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: scipy
BuildRequires: fftw-devel >= 3
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
BuildRequires: graphviz
BuildRequires: gsl-devel
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: fftw-devel >= 3
BuildRequires: %{gstreamername}-devel >= @MIN_GSTREAMER_VERSION@
BuildRequires: %{gstreamername}-plugins-base-devel >= @MIN_GSTREAMER_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: gsl-devel
BuildRequires: graphviz
BuildRequires: orc >= @MIN_ORC_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: python-lal >= @MIN_LAL_VERSION@
Conflicts: gstlal-ugly < 0.6.0
Source: @PACKAGE_NAME@-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/gstlal.html
......
......@@ -15,9 +15,7 @@ Build-Depends:
gstlal-ugly-dev (>= @MIN_GSTLALUGLY_VERSION@),
gtk-doc-tools (>= @MIN_GTK_DOC_VERSION@),
lal-dev (>= @MIN_LAL_VERSION@),
lal-python (>= @MIN_LAL_VERSION@),
lalinspiral-dev (>= @MIN_LALINSPIRAL_VERSION@),
lalinspiral-python (>= @MIN_LALINSPIRAL_VERSION@),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
libgirepository1.0-dev (>= @MIN_GOBJECT_INTROSPECTION_VERSION@),
libgsl-dev (>= 1.9),
......@@ -27,7 +25,9 @@ Build-Depends:
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-glue-ligolw-tools,
python-gobject-dev
python-gobject-dev,
python-lal (>= @MIN_LAL_VERSION@),
python-lalinspiral (>= @MIN_LALINSPIRAL_VERSION@)
Package: gstlal-inspiral
Architecture: any
......@@ -35,9 +35,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
gstlal (>= @MIN_GSTLAL_VERSION@),
gstlal-ugly (>= @MIN_GSTLALUGLY_VERSION@),
lal (>= @MIN_LAL_VERSION@),
lal-python (>= @MIN_LAL_VERSION@),
lalinspiral (>= @MIN_LALINSPIRAL_VERSION@),
lalinspiral-python (>= @MIN_LALINSPIRAL_VERSION@),
lalmetaio (>= @MIN_LALMETAIO_VERSION@),
libgirepository-1.0-1 (>= @MIN_GOBJECT_INTROSPECTION_VERSION@),
libgstreamer1.0-0 (>= @MIN_GSTREAMER_VERSION@),
......@@ -48,6 +46,8 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
python-gobject,
python-gst-1.0,
python-h5py,
python-lal (>= @MIN_LAL_VERSION@),
python-lalinspiral (>= @MIN_LALINSPIRAL_VERSION@),
python-ligo-gracedb (>= 1.11),
python-ligo-lw (>= @MIN_LIGO_LW_VERSION@),
python-ligo-segments (>= @MIN_LIGO_SEGMENTS_VERSION@),
......
......@@ -8,41 +8,41 @@ License: GPL
Group: LSC Software/Data Analysis
Requires: gstlal >= @MIN_GSTLAL_VERSION@
Requires: gstlal-ugly >= @MIN_GSTLALUGLY_VERSION@
Requires: python >= @MIN_PYTHON_VERSION@
Requires: glue >= @MIN_GLUE_VERSION@
Requires: python-ligo-lw >= @MIN_LIGO_LW_VERSION@
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: %{gstreamername} >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-base >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-good >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-bad-free
Requires: gsl
Requires: h5py
Requires: numpy >= @MIN_NUMPY_VERSION@
Requires: scipy
Requires: lal >= @MIN_LAL_VERSION@
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: lalinspiral-python >= @MIN_LALINSPIRAL_VERSION@
Requires: gsl
Requires: ligo-gracedb >= 1.11
Requires: python >= @MIN_PYTHON_VERSION@
Requires: python-%{gstreamername}
BuildRequires: pkgconfig >= 0.18.0
Requires: python-lal >= @MIN_LAL_VERSION@
Requires: python-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: python-ligo-lw >= @MIN_LIGO_LW_VERSION@
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: numpy >= @MIN_NUMPY_VERSION@
Requires: scipy
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
BuildRequires: graphviz
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: %{gstreamername}-devel >= @MIN_GSTREAMER_VERSION@
BuildRequires: %{gstreamername}-plugins-base-devel >= @MIN_GSTREAMER_VERSION@
BuildRequires: gsl-devel
BuildRequires: gtk-doc >= @MIN_GTK_DOC_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: lalinspiral-python >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: gsl-devel
BuildRequires: gtk-doc >= @MIN_GTK_DOC_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: python-lal >= @MIN_LAL_VERSION@
BuildRequires: python-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Source: @PACKAGE_NAME@-%{version}.tar.gz
URL: https://wiki.ligo.org/DASWG/GstLAL
Packager: Kipp Cannon <kipp.cannon@ligo.org>
......
......@@ -13,7 +13,6 @@ Build-Depends:
graphviz,
gtk-doc-tools (>= @MIN_GTK_DOC_VERSION@),
lal-dev (>= @MIN_LAL_VERSION@),
lal-python (>= @MIN_LAL_VERSION@),
lalburst-dev (>= @MIN_LALBURST_VERSION@),
lalinspiral-dev (>= @MIN_LALINSPIRAL_VERSION@),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
......@@ -28,6 +27,7 @@ Build-Depends:
pkg-config (>= 0.18.0),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-gi-dev (>= @MIN_PYGOBJECT_VERSION@),
python-lal (>= @MIN_LAL_VERSION@),
python-numpy-dev (>= @MIN_NUMPY_VERSION@),
zlib1g-dev
......@@ -46,7 +46,6 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
gstreamer1.0-plugins-ugly,
gstreamer1.0-tools (>= @MIN_GSTREAMER_VERSION@),
lal (>= @MIN_LAL_VERSION@),
lal-python (>= @MIN_LAL_VERSION@),
lalburst (>= @MIN_LALBURST_VERSION@),
lalinspiral (>= @MIN_LALINSPIRAL_VERSION@),
lalmetaio (>= @MIN_LALMETAIO_VERSION@),
......@@ -63,6 +62,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
python-gi (>= @MIN_PYGOBJECT_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-gst-1.0,
python-lal (>= @MIN_LAL_VERSION@),
python-ligo-lw (>= @MIN_LIGO_LW_VERSION@),
python-ligo-segments (>= @MIN_LIGO_SEGMENTS_VERSION@),
python-numpy (>= @MIN_NUMPY_VERSION@),
......
......@@ -11,8 +11,6 @@ Requires: avahi-glib
Requires: avahi-ui-tools
Requires: fftw >= 3
Requires: glue >= @MIN_GLUE_VERSION@
Requires: python-ligo-lw >= @MIN_LIGO_LW_VERSION@
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: gsl
Requires: %{gstreamername} >= @MIN_GSTREAMER_VERSION@
......@@ -25,7 +23,6 @@ Requires: %{gstreamername}-plugins-good >= @MIN_GSTREAMER_VERSION@
# FIXME: add this when it becomes available
#Requires: %{gstreamername}-rtsp-server >= @MIN_GSTREAMER_VERSION@
Requires: lal >= @MIN_LAL_VERSION@
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalinspiral >= @MIN_LALINSPIRAL_VERSION@
......@@ -35,9 +32,11 @@ Requires: orc >= @MIN_ORC_VERSION@
Requires: python >= @MIN_PYTHON_VERSION@
Requires: python-%{gstreamername}
Requires: python-gobject >= @MIN_PYGOBJECT_VERSION@
Requires: python-lal >= @MIN_LAL_VERSION@
Requires: python-ligo-lw >= @MIN_LIGO_LW_VERSION@
Requires: python2-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: scipy
Requires: zlib
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: fftw-devel >= 3
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
......@@ -49,16 +48,17 @@ BuildRequires: %{gstreamername}-plugins-base-devel >= @MIN_GSTREAMER_VERSION@
# FIXME: add this when it becomes available
#BuildRequires: %{gstreamername}-rtsp-server-devel >= @MIN_GSTREAMER_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: numpy >= @MIN_NUMPY_VERSION@
BuildRequires: orc >= @MIN_ORC_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
# needed for gstpythonplugin.c remove when we remove that plugin from gstlal
BuildRequires: pygobject3-devel >= @MIN_PYGOBJECT_VERSION@
BuildRequires: python-lal >= @MIN_LAL_VERSION@
BuildRequires: zlib-devel
Source: @PACKAGE_NAME@-%{version}.tar.gz
URL: https://wiki.ligo.org/DASWG/GstLAL
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment