Commit 678e6954 authored by Kipp Cannon's avatar Kipp Cannon

all: use macro for min pkg-config version

- this fixes a maintainance problem introduced by 70c88cd6 "use private fields in pkgconfig files"
parent be95313c
......@@ -99,7 +99,8 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG(0.18.0)
AC_SUBST([MIN_PKG_CONFIG_VERSION], [0.18.0])
PKG_PROG_PKG_CONFIG("$MIN_PKG_CONFIG_VERSION")
#
......
......@@ -13,7 +13,7 @@ Build-Depends:
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
fakeroot,
pkg-config (>= 0.18.0),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
gstlal-dev (>= @MIN_GSTLAL_VERSION@),
gstlal-ugly-dev (>= @MIN_GSTLAL_UGLY_VERSION@)
......
......@@ -37,7 +37,7 @@ BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: orc >= @MIN_ORC_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: pkgconfig >= @MIN_PKG_CONFIG_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: python2-lal >= @MIN_LAL_VERSION@
Conflicts: gstlal-ugly < 0.6.0
......
......@@ -97,7 +97,8 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG(0.18.0)
AC_SUBST([MIN_PKG_CONFIG_VERSION], [0.18.0])
PKG_PROG_PKG_CONFIG("$MIN_PKG_CONFIG_VERSION")
#
......
......@@ -12,7 +12,7 @@ Build-Depends:
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
libgstreamer1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
pkg-config (>= 0.18.0),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-numpy
......
......@@ -20,7 +20,7 @@ Requires: scipy
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: pkgconfig >= @MIN_PKG_CONFIG_VERSION@
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: fftw-devel >= 3
......
......@@ -107,7 +107,8 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG(0.18.0)
AC_SUBST([MIN_PKG_CONFIG_VERSION], [0.18.0])
PKG_PROG_PKG_CONFIG("$MIN_PKG_CONFIG_VERSION")
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -21,7 +21,7 @@ Build-Depends:
libgsl-dev (>= 1.9),
libgstreamer1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
pkg-config (>= 0.18.0),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-gobject-dev,
......
......@@ -40,7 +40,7 @@ BuildRequires: gtk-doc >= @MIN_GTK_DOC_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: pkgconfig >= @MIN_PKG_CONFIG_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: python2-lal >= @MIN_LAL_VERSION@
BuildRequires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
......
......@@ -104,7 +104,8 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG(0.18.0)
AC_SUBST([MIN_PKG_CONFIG_VERSION], [0.18.0])
PKG_PROG_PKG_CONFIG("$MIN_PKG_CONFIG_VERSION")
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -25,7 +25,7 @@ Build-Depends:
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libnds2-client-dev (>= @MIN_NDS_VERSION@),
liborc-0.4-dev (>= 1:@MIN_ORC_VERSION@),
pkg-config (>= 0.18.0),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-numpy (>= @MIN_NUMPY_VERSION@)
......
......@@ -29,7 +29,7 @@ Requires: gds-lowlatency >= @MIN_GDS_VERSION@
Requires: nds2-client >= @MIN_NDS_VERSION@
Requires: orc >= @MIN_ORC_VERSION@
Requires: python-%{gstreamername}
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: pkgconfig >= @MIN_PKG_CONFIG_VERSION@
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: graphviz
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
......
......@@ -101,7 +101,8 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG(0.18.0)
AC_SUBST([MIN_PKG_CONFIG_VERSION], [0.18.0])
PKG_PROG_PKG_CONFIG("$MIN_PKG_CONFIG_VERSION")
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -24,7 +24,7 @@ Build-Depends:
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstrtspserver-1.0-dev (>= @MIN_GSTREAMER_VERSION@),
liborc-0.4-dev (>= 1:@MIN_ORC_VERSION@),
pkg-config (>= 0.18.0),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-gi-dev (>= @MIN_PYGOBJECT_VERSION@),
python-lal (>= @MIN_LAL_VERSION@),
......
......@@ -54,7 +54,7 @@ BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: numpy >= @MIN_NUMPY_VERSION@
BuildRequires: orc >= @MIN_ORC_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: pkgconfig >= @MIN_PKG_CONFIG_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
# needed for gstpythonplugin.c remove when we remove that plugin from gstlal
BuildRequires: pygobject3-devel >= @MIN_PYGOBJECT_VERSION@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment