Commit 70c88cd6 authored by Duncan Macleod's avatar Duncan Macleod

use private fields in pkgconfig files

- use `Requires.private` in pkgconfig files to stop forcing downstream
  packages to link against everything upstream
- added `pkgconfig` as `BuildRequires` for RPMs
- bumped required version of pkg-config to 0.18.0
parent 6597d318
......@@ -99,7 +99,7 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_PROG_PKG_CONFIG(0.18.0)
#
......
......@@ -13,7 +13,7 @@ Build-Depends:
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
fakeroot,
pkg-config,
pkg-config (>= 0.18.0),
gstlal-dev (>= @MIN_GSTLAL_VERSION@),
gstlal-ugly-dev (>= @MIN_GSTLAL_UGLY_VERSION@)
......
......@@ -26,6 +26,7 @@ Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: orc >= @MIN_ORC_VERSION@
Requires: gsl
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
......
......@@ -6,6 +6,6 @@ includedir=@includedir@
Name: libgstlalburst
Description: LAL/Gstreamer Library (the bursty bits)
Version: @VERSION@
Requires: lal lalmetaio lalburst gstlal
Requires.private: lal lalmetaio lalburst gstlal
Libs: -L${libdir} -lgstlalburst
Cflags: -I${includedir}
......@@ -96,7 +96,7 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_PROG_PKG_CONFIG(0.18.0)
#
......
......@@ -12,7 +12,7 @@ Build-Depends:
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
libgstreamer1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
pkg-config,
pkg-config (>= 0.18.0),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-numpy
......
......@@ -21,6 +21,7 @@ Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: gst-plugins-math >= @MIN_GSTPLUGINSMATH_VERSION@
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
BuildRequires: python-devel >= @MIN_PYTHON_VERSION@
BuildRequires: fftw-devel >= 3
......
......@@ -107,7 +107,7 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_PROG_PKG_CONFIG(0.18.0)
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -23,7 +23,7 @@ Build-Depends:
libgsl-dev (>= 1.9),
libgstreamer1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
pkg-config,
pkg-config (>= 0.18.0),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-glue-ligolw-tools,
......
......@@ -28,6 +28,7 @@ Requires: lalinspiral-python >= @MIN_LALINSPIRAL_VERSION@
Requires: gsl
Requires: ligo-gracedb >= 1.11
Requires: python-%{gstreamername}
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
BuildRequires: graphviz
......
......@@ -105,7 +105,7 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_PROG_PKG_CONFIG(0.18.0)
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -25,7 +25,7 @@ Build-Depends:
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libnds2-client-dev (>= @MIN_NDS_VERSION@),
liborc-0.4-dev (>= 1:@MIN_ORC_VERSION@),
pkg-config,
pkg-config (>= 0.18.0),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-glue (>= @MIN_GLUE_VERSION@),
python-glue-ligolw-tools,
......
......@@ -28,6 +28,7 @@ Requires: gds-lowlatency >= @MIN_GDS_VERSION@
Requires: nds2-client >= @MIN_NDS_VERSION@
Requires: orc >= @MIN_ORC_VERSION@
Requires: python-%{gstreamername}
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: graphviz
BuildRequires: gstlal-devel >= @MIN_GSTLAL_VERSION@
......
......@@ -101,7 +101,7 @@ case `cat /etc/redhat-release 2> /dev/null` in
;;
esac
LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_PROG_PKG_CONFIG(0.18.0)
MIN_DOXYGEN_VERSION="1.8.3"
GSTLAL_DOXYGEN([$MIN_DOXYGEN_VERSION])
......
......@@ -25,7 +25,7 @@ Build-Depends:
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstrtspserver-1.0-dev (>= @MIN_GSTREAMER_VERSION@),
liborc-0.4-dev (>= 1:@MIN_ORC_VERSION@),
pkg-config,
pkg-config (>= 0.18.0),
python-all-dev (>= @MIN_PYTHON_VERSION@),
python-gi-dev (>= @MIN_PYGOBJECT_VERSION@),
python-numpy-dev (>= @MIN_NUMPY_VERSION@),
......
......@@ -37,6 +37,7 @@ Requires: python-%{gstreamername}
Requires: python-gobject >= @MIN_PYGOBJECT_VERSION@
Requires: scipy
Requires: zlib
BuildRequires: pkgconfig >= 0.18.0
BuildRequires: doxygen >= @MIN_DOXYGEN_VERSION@
BuildRequires: fftw-devel >= 3
BuildRequires: gobject-introspection-devel >= @MIN_GOBJECT_INTROSPECTION_VERSION@
......
......@@ -6,6 +6,6 @@ includedir=@includedir@
Name: libgstlal
Description: LAL/Gstreamer Library
Version: @VERSION@
Requires: fftw3 gsl lal lalframe lalmetaio lalsupport lalburst gstreamer-@GSTREAMER_RELEASE@ gstreamer-base-@GSTREAMER_RELEASE@ gstreamer-audio-@GSTREAMER_RELEASE@ gstreamer-video-@GSTREAMER_RELEASE@ gstreamer-plugins-base-@GSTREAMER_RELEASE@
Requires.private: fftw3 gsl lal lalframe lalmetaio lalsupport lalburst gstreamer-@GSTREAMER_RELEASE@ gstreamer-base-@GSTREAMER_RELEASE@ gstreamer-audio-@GSTREAMER_RELEASE@ gstreamer-video-@GSTREAMER_RELEASE@ gstreamer-plugins-base-@GSTREAMER_RELEASE@
Libs: -L${libdir} -lgstlal -lgstlaltags -lgstlaltypes
Cflags: -I${includedir}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment