Commit fed97b27 authored by Kipp Cannon's avatar Kipp Cannon

gstlal-calibration: tweak packaging files, bump version to 0.99.1

- remove reference to python elements and to interleave plugin
- update name of gstreamer python bindings RPM
- don't source gstenvironment.sh in .spec
- bump minimum required gstlal and gstlal-ugly for ER9
parent 53610865
......@@ -3,7 +3,7 @@
#
AC_INIT([gstlal-calibration],[0.99.0],[gstlal-discuss@ligo.org],[gstlal-calibration])
AC_INIT([gstlal-calibration],[0.99.1],[gstlal-discuss@ligo.org],[gstlal-calibration])
AC_COPYRIGHT([Copyright (C) 2008--2016 Madeline Wade])
# a file whose existance can be used to use to check that we are in the
# top-level directory of the source tree
......@@ -229,8 +229,8 @@ AX_PYTHON_PYLAL()
#
AC_SUBST([MIN_GSTLAL_VERSION], [0.99.0])
AC_SUBST([MIN_GSTLALUGLY_VERSION], [0.99.0])
AC_SUBST([MIN_GSTLAL_VERSION], [0.99.4])
AC_SUBST([MIN_GSTLALUGLY_VERSION], [0.99.2])
PKG_CHECK_MODULES([GSTLAL], [gstlal >= ${MIN_GSTLAL_VERSION}])
AC_SUBST([GSTLAL_VERSION], [`$PKG_CONFIG --modversion gstlal`])
AX_GSTLAL_SPLIT_VERSION([GSTLAL_VERSION])
......
gstlal-calibration (0.99.1-1) unstable; urgency=low
* More packaging related adjustments
-- Kipp Cannon <kipp.cannon@ligo.org> Wed, 05 Jul 2016 16:22:00 +0900
gstlal-calibration (0.99.0-2) unstable; urgency=low
* A few updates to the .spec file for dependencies
......
usr/bin/*
usr/lib/gstreamer-*/python/*
usr/lib/gstreamer-*/libgstlalcalibration.a
usr/lib/gstreamer-*/libgstlalcalibration.so
usr/lib/gstreamer-*/libgstlalinterleave.a
usr/lib/gstreamer-*/libgstlalinterleave.so
usr/lib/gstreamer-*/libgstlalcalibration.*
......@@ -15,8 +15,8 @@ Requires: glue-segments >= @MIN_GLUE_VERSION@
Requires: python-pylal >= @MIN_PYLAL_VERSION@
Requires: %{gstreamername} >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-base >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-good >= 1.2.4
Requires: %{gstreamername}-python >= 0.10.21
Requires: %{gstreamername}-plugins-good >= @MIN_GSTREAMER_VERSION@
Requires: python-%{gstreamername}
Requires: numpy
Requires: scipy
Requires: lal >= @MIN_LAL_VERSION@
......@@ -44,7 +44,6 @@ This package contains the plugins and shared libraries required to run the gstla
%build
. /opt/lscsoft/gst/gstenvironment.sh
%configure
%{__make}
......@@ -85,11 +84,5 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}
%files
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/gstreamer-1.0/python/*
%{_libdir}/gstreamer-1.0/libgstlalcalibration.a
%{_libdir}/gstreamer-1.0/libgstlalcalibration.so
%{_libdir}/gstreamer-1.0/libgstlaldeinterleave.a
%{_libdir}/gstreamer-1.0/libgstlaldeinterleave.so
%{_libdir}/gstreamer-1.0/libgstlalinterleave.a
%{_libdir}/gstreamer-1.0/libgstlalinterleave.so
%{_libdir}/gstreamer-*/libgstlalcalibration.*
%{_prefix}/%{_lib}/python*/site-packages/gstlal
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment