Commit be47b2b6 authored by John Douglas Veitch's avatar John Douglas Veitch
Browse files

Merge branch 'setup' into 'master'

Clean up requirements.txt

Closes #22

See merge request cbc-cosmo/gwcosmo!29
parents 608c9103 b8bd2c43
......@@ -6,7 +6,6 @@ import numpy as _np
from scipy.stats import truncnorm as _truncnorm
import copy as _copy
from scipy.interpolate import interp1d as _interp1d
import bilby as _bilby
from scipy.special import erf as _erf
from scipy.special import logsumexp as _logsumexp
from scipy.integrate import cumtrapz as _cumtrapz
......
astroplan==0.7
astropy==4.1
astropy-healpix==0.5
backcall==0.2.0
bilby==1.0.4
cached-property==1.5.2
certifi==2020.12.5
cffi==1.14.4
chardet==4.0.0
corner==2.1.0
cryptography==3.4.3
cycler==0.10.0
decorator==4.4.2
dill==0.3.3
dynesty==1.0.1
emcee==3.0.2
future==0.18.2
h5py==3.1.0
healpy==1.14.0
idna==2.10
importlib-resources==5.1.0
ipykernel==5.4.3
ipython==7.16.1
ipython-genutils==0.2.0
jedi==0.18.0
jupyter-client==6.1.11
jupyter-core==4.7.1
kiwisolver==1.3.1
lalsuite==6.81
ligo-gracedb==2.7.5
ligo-segments==1.3.0
ligo.skymap==0.5.0
lscsoft-glue==2.0.0
matplotlib==3.3.4
networkx==2.5
numpy==1.19.5
pandas==1.1.5
parso==0.8.1
pexpect==4.8.0
pickleshare==0.7.5
Pillow==8.1.0
progressbar==2.5
prompt-toolkit==3.0.14
ptemcee==1.0.0
ptyprocess==0.7.0
pycparser==2.20
Pygments==2.7.4
pyOpenSSL==20.0.1
pyparsing==2.4.7
python-dateutil==2.8.1
python-ligo-lw==1.7.0
pytz==2021.1
PyYAML==5.4.1
pyzmq==22.0.2
reproject==0.7.1
requests==2.25.1
scipy==1.5.4
seaborn==0.11.1
setuptools-scm==5.0.1
six==1.15.0
tornado==6.1
tqdm==4.56.0
traitlets==4.3.3
urllib3==1.26.3
wcwidth==0.2.5
zipp==3.4.0
argparse
astropy
h5py
healpy
importlib-resources
lalsuite
ligo-gracedb
ligo-segments
ligo.skymap
lscsoft-glue
matplotlib>=2.0
numpy>=1.19
pandas
progressbar
scipy
seaborn
tqdm
......@@ -12,6 +12,9 @@ def readme():
with open('README.md') as f:
return f.read()
with open('requirements.txt') as f:
reqs = f.read()
setup(name='gwcosmo',
version='0.1.0',
description='A package to estimate cosmological parameters using gravitational-wave observations',
......@@ -23,12 +26,7 @@ setup(name='gwcosmo',
package_dir={'gwcosmo': 'gwcosmo'},
scripts=['bin/gwcosmo_single_posterior', 'bin/gwcosmo_combined_posterior', 'bin/gwcosmo_compute_pdet', 'bin/gwcosmo_pixel_dag'],
include_package_data=True,
install_requires=[
'numpy>=1.9',
'matplotlib>=2.0',
'pandas',
'scipy',
'tqdm'],
install_requires=reqs,
setup_requires=setup_requires,
zip_safe=False)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment