control.in 2.9 KB
Newer Older
1
2
3
4
Source: lalapps
Section: science
Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Build-Depends: bc,
  debhelper (>= 9),
  dh-python,
  help2man,
  less,
  libcfitsio3-dev,
  libfftw3-dev,
  libframe-dev (>= 8.0),
  libgsl-dev | libgsl0-dev (>= 1.9),
  libmetaio-dev (>= 8.2),
  libopenmpi-dev,
  pkg-config,
  python-all-dev,
  zlib1g-dev,
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
  lal-dev (>= @MIN_LAL_VERSION@~),
  lal-python (>= @MIN_LAL_VERSION@~),
  lalframe-dev (>= @MIN_LALFRAME_VERSION@~),
  lalframe-python (>= @MIN_LALFRAME_VERSION@~),
  lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
  lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
  lalxml-dev (>= @MIN_LALXML_VERSION@~),
  lalxml-python (>= @MIN_LALXML_VERSION@~),
  lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
  lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
  lalburst-dev (>= @MIN_LALBURST_VERSION@~),
  lalburst-python (>= @MIN_LALBURST_VERSION@~),
  lalinspiral-dev (>= @MIN_LALINSPIRAL_VERSION@~),
  lalinspiral-python (>= @MIN_LALINSPIRAL_VERSION@~),
  lalpulsar-dev (>= @MIN_LALPULSAR_VERSION@~),
  lalpulsar-python (>= @MIN_LALPULSAR_VERSION@~),
  lalstochastic-dev (>= @MIN_LALSTOCHASTIC_VERSION@~),
  lalstochastic-python (>= @MIN_LALSTOCHASTIC_VERSION@~),
  lalinference-dev (>= @MIN_LALINFERENCE_VERSION@~),
38
  lalinference-python (>= @MIN_LALINFERENCE_VERSION@~)
39
X-Python-Version: >= 2.7
40
X-Python3-Version: <= 3.0
41
42
43
44
Standards-Version: 3.9.8

Package: lalapps
Architecture: any
45
46
47
48
49
50
51
52
53
54
Depends: ${misc:Depends},
  ${python:Depends},
  ${shlibs:Depends},
  less,
  libframe1 (>= 8.0),
  libmetaio1 (>= 8.2),
  python-h5py,
  python-healpy,
  python-skyarea,
  zlib1g,
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
  lal (>= @MIN_LAL_VERSION@~),
  lal-python (>= @MIN_LAL_VERSION@~),
  lalframe (>= @MIN_LALFRAME_VERSION@~),
  lalframe-python (>= @MIN_LALFRAME_VERSION@~),
  lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
  lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
  lalxml (>= @MIN_LALXML_VERSION@~),
  lalxml-python (>= @MIN_LALXML_VERSION@~),
  lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
  lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
  lalburst (>= @MIN_LALBURST_VERSION@~),
  lalburst-python (>= @MIN_LALBURST_VERSION@~),
  lalinspiral (>= @MIN_LALINSPIRAL_VERSION@~),
  lalinspiral-python (>= @MIN_LALINSPIRAL_VERSION@~),
  lalpulsar (>= @MIN_LALPULSAR_VERSION@~),
  lalpulsar-python (>= @MIN_LALPULSAR_VERSION@~),
  lalstochastic (>= @MIN_LALSTOCHASTIC_VERSION@~),
  lalstochastic-python (>= @MIN_LALSTOCHASTIC_VERSION@~),
  lalinference (>= @MIN_LALINFERENCE_VERSION@~),
74
  lalinference-python (>= @MIN_LALINFERENCE_VERSION@~)
75
76
Provides: python-bayestar-localization, python-bayestar
Conflicts: python-bayestar-localization, python-bayestar
77
Replaces: python-bayestar-localization, python-bayestar
78
79
80
81
Description: LSC Algorithm Library Applications
 The LSC Algorithm Library Applications for gravitational wave data analysis.
 This package contains applications that are built on tools in the
 LSC Algorithm Library.