lalinference.spec.in 8.11 KB
Newer Older
1
%define nightly @NIGHTLY_VERSION@%{nil}
2
%define _prefix /usr
3 4
%define _mandir %{_prefix}/share/man
%define _sysconfdir %{_prefix}/etc
Adam Mercer's avatar
Adam Mercer committed
5
%define release 1
6

7 8 9 10
%if "%{?nightly:%{nightly}}%{!?nightly:0}" == "%{nil}"
%undefine nightly
%endif

11
Name: @PACKAGE@
Adam Mercer's avatar
Adam Mercer committed
12 13
Version: @BASE_VERSION@
Release: %{?nightly:0.%{nightly}}%{!?nightly:%{release}}%{?dist}
14
Summary: LSC Algorithm Inference Library
15
License: GPLv2+
16
Group: LAL
Adam Mercer's avatar
Adam Mercer committed
17
Source: %{name}-%{version}%{?nightly:-%{nightly}}.tar.xz
18
URL: https://wiki.ligo.org/Computing/DASWG/LALSuite
19
Packager: Adam Mercer <adam.mercer@ligo.org>
20
BuildRequires: python2-rpm-macros
21
BuildRequires: chealpix-devel >= 3.30.0
22
BuildRequires: gsl-devel
23
BuildRequires: hdf5-devel
24
BuildRequires: healpy >= 1.9.1
25
BuildRequires: python-astropy >= 1.1.1
26
BuildRequires: python-matplotlib >= 1.2.0
27
BuildRequires: h5py
28
BuildRequires: python-shapely
29
BuildRequires: pytest
30
BuildRequires: libmetaio-devel
31
BuildRequires: numpy >= 1.7
32 33
BuildRequires: octave-devel
BuildRequires: python-devel
34
BuildRequires: scipy >= 0.8
35
BuildRequires: swig >= 3.0.7
36
BuildRequires: glue >= @MIN_GLUE_VERSION@
37 38
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
39
BuildRequires: python2-lal >= @MIN_LAL_VERSION@
40 41
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
42
BuildRequires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
43 44
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
45
BuildRequires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
46 47
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalburst-octave >= @MIN_LALBURST_VERSION@
48
BuildRequires: python2-lalburst >= @MIN_LALBURST_VERSION@
49 50
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: lalinspiral-octave >= @MIN_LALINSPIRAL_VERSION@
51
BuildRequires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
52 53
BuildRequires: lalpulsar-devel >= @MIN_LALPULSAR_VERSION@
BuildRequires: lalpulsar-octave >= @MIN_LALPULSAR_VERSION@
54
BuildRequires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
55 56
Requires: chealpix
Requires: gsl >= 1.15
57
Requires: hdf5
58
Requires: libmetaio
59 60 61 62 63 64
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar >= @MIN_LALPULSAR_VERSION@
65 66 67 68 69 70 71 72 73 74 75
Prefix: %{_prefix}

%description
The LSC Algorithm Inference Library for gravitational wave data analysis. This
package contains the shared-object libraries needed to run applications
that use the LAL Inference library.

%package devel
Summary: Files and documentation needed for compiling programs that use LAL Inference
Group: LAL
Requires: %{name} = %{version}
76
Requires: chealpix-devel >= 3.30.0
77 78
Requires: gsl-devel >= 1.15
Requires: libmetaio-devel
79 80 81 82 83 84
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-devel >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar-devel >= @MIN_LALPULSAR_VERSION@
85 86 87 88 89
%description devel
The LSC Algorithm Inference Library for gravitational wave data analysis. This
package contains files needed build applications that use the LAL Inference
library.

90 91
%package -n python2-%{name}
Summary: Python %{python2_version} Bindings for LALInference
92 93
Group: LAL
Requires: %{name} = %{version}
94
Requires: healpy >= 1.9.1
95
Requires: h5py
96
Requires: python-shapely
97
Requires: numpy >= 1.7
98
Requires: python
99
Requires: scipy >= 0.8
100
Requires: python-astropy >= 1.1.1
101
Requires: python-matplotlib >= 1.2.0
Leo Pound Singer's avatar
Leo Pound Singer committed
102
Requires: python-six
103
Requires: python-seaborn
104
Requires: glue >= @MIN_GLUE_VERSION@
105
Requires: ligo-gracedb
106
Requires: python-gwpy
107 108 109 110 111 112
Requires: python2-lal >= @MIN_LAL_VERSION@
Requires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: python2-lalburst >= @MIN_LALBURST_VERSION@
Requires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
113 114
Obsoletes: %{name}-python
Provides: %{name}-python
115
%description -n python2-%{name}
116
The LSC Algorithm Library for gravitational wave data analysis.
117
This package provides the Python %{python2_version} bindings for LALInference.
118 119 120 121 122

%package octave
Summary: Octave Bindings for LALInference
Group: LAL
Requires: %{name} = %{version}
123
Requires: octave
124 125 126 127 128 129
Requires: lal-octave >= @MIN_LAL_VERSION@
Requires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-octave >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-octave >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar-octave >= @MIN_LALPULSAR_VERSION@
130 131 132 133
%description octave
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Octave bindings for LALInference.

134
%prep
Adam Mercer's avatar
Adam Mercer committed
135
%setup -q -n %{name}-%{version}%{?nightly:-%{nightly}}
136 137

%build
138
%configure --disable-gcc-flags --enable-swig --enable-openmp
Adam Mercer's avatar
Adam Mercer committed
139
%{__make} %{?_smp_mflags} V=1
140

141
%check
142
%{__make} %{?_smp_mflags} V=1 VERBOSE=1 check
143

144
%install
145
%make_install
Adam Mercer's avatar
Adam Mercer committed
146
find $RPM_BUILD_ROOT%{_libdir} -name '*.la' -delete
147 148 149 150 151 152 153 154 155

%post
ldconfig

%postun
ldconfig

%clean
[ ${RPM_BUILD_ROOT} != "/" ] && rm -Rf ${RPM_BUILD_ROOT}
Adam Mercer's avatar
Adam Mercer committed
156
rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
157 158 159

%files
%defattr(-,root,root)
160
%license COPYING
161 162 163 164 165 166 167
%{_bindir}/lalinference_bench
%{_bindir}/lalinference_burst
%{_bindir}/lalinference_datadump
%{_bindir}/lalinference_injectedlike
%{_bindir}/lalinference_nest
%{_bindir}/lalinference_version
%{_bindir}/lalinference_mpi_wrapper
168
%{_datarootdir}/lalinference/*
169
%{_libdir}/*.so.*
170 171 172 173
%{_sysconfdir}/*

%files devel
%defattr(-,root,root)
174
%license COPYING
175
%{_includedir}/lal
176
%{_libdir}/*.a
177
%{_libdir}/*.so
178
%{_libdir}/pkgconfig/*
179

180
%files -n python2-%{name}
181
%defattr(-,root,root)
182
%license COPYING
183
%{_bindir}/cbcBayes*
Adam Mercer's avatar
Adam Mercer committed
184
%{_bindir}/imrtgr_*
185 186 187 188 189 190 191 192 193 194
%{_bindir}/lalinference_burst_pp_pipe
%{_bindir}/lalinference_coherence_test
%{_bindir}/lalinference_compute_roq_weights
%{_bindir}/lalinference_merge_posteriors
%{_bindir}/lalinference_multi_pipe
%{_bindir}/lalinference_nest2pos
%{_bindir}/lalinference_pipe
%{_bindir}/lalinference_pp_pipe
%{_bindir}/lalinference_review_test
%{_bindir}/lalinference_tiger_pipe
195
%{_bindir}/rapidpe_*
196
%{python2_sitearch}/*
197 198 199

%files octave
%defattr(-,root,root)
200
%license COPYING
201
%{_prefix}/lib*/octave/*/site/oct/*/lalinference.oct*
202 203 204

# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
205 206 207
* Tue Jan 22 2019 Adam Mercer <adam.mercer@ligo.org> 1.10.1-1
- Fix spin2 prior

208 209 210
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 1.10.0-1
- Pre O3 release

211 212 213
* Thu Jul 27 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.4-1
- bayestar_plot_volume: work around broken fonts in SL7

214 215 216
* Wed Jul 26 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.3-1
- BAYESTAR and sky map post-processing updates

217 218 219 220
* Thu Mar 16 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.2-1
- lalinference.io.fits: remove some redundant keys on reading
- lalinference.io.fits: fix writing single-column sky maps

221 222 223 224 225 226 227 228 229
* Sat Feb 18 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.1-1
- Do not use $(..._la_LIBADD) to link against external libraries
- Track version info API change
- Fix to weights calculation so that posterior samples are now drawn correctly
- Fix incorrect axes limits for Mollweide sky maps
- Drop code for reading past EOF of named pipe
- Fix incorrect reordering of IDL-compatible sky maps
- Tune default max distance for volume rendering plots

230 231 232
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.0-1
- O2 release

233 234 235 236
* Thu Dec 15 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.2-1
- Be more emphatic about switching matplotlib backend
- Prevent trying to build python3 packages when unsupported

237 238 239 240
* Fri Dec 09 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.1-1
- Explicitly set no-op Matplotlib backend
- Set matplotlib backend to no-op

241 242 243
* Mon Sep 26 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.0-1
- ER10 release

244 245 246
* Thu Jun 23 2016 Adam Mercer <adam.mercer@ligo.org> 1.7.0-1
- ER9 release

247 248
* Fri Mar 25 2016 Adam Mercer <adam.mercer@ligo.org> 1.6.0-1
- Pre O2 packaging test release