lalinference.spec.in 8.22 KB
Newer Older
1
%define nightly @NIGHTLY_VERSION@%{nil}
2
%define _prefix /usr
3 4
%define _mandir %{_prefix}/share/man
%define _sysconfdir %{_prefix}/etc
Adam Mercer's avatar
Adam Mercer committed
5
%define release 1
6

7 8 9 10
%if "%{?nightly:%{nightly}}%{!?nightly:0}" == "%{nil}"
%undefine nightly
%endif

11
Name: @PACKAGE@
Adam Mercer's avatar
Adam Mercer committed
12 13
Version: @BASE_VERSION@
Release: %{?nightly:0.%{nightly}}%{!?nightly:%{release}}%{?dist}
14
Summary: LSC Algorithm Inference Library
15
License: GPLv2+
16
Group: LAL
Adam Mercer's avatar
Adam Mercer committed
17
Source: %{name}-%{version}%{?nightly:-%{nightly}}.tar.xz
18
URL: https://wiki.ligo.org/Computing/DASWG/LALSuite
19
Packager: Adam Mercer <adam.mercer@ligo.org>
20
BuildRequires: python2-rpm-macros
21
BuildRequires: pkgconfig >= 0.18.0
22
BuildRequires: chealpix-devel >= 3.30.0
23
BuildRequires: gsl-devel
24
BuildRequires: hdf5-devel
25
BuildRequires: healpy >= 1.9.1
26
BuildRequires: python-astropy >= 1.1.1
27
BuildRequires: python-matplotlib >= 1.2.0
28
BuildRequires: h5py
29
BuildRequires: python-shapely
30
BuildRequires: pytest
31
BuildRequires: libmetaio-devel
32
BuildRequires: numpy >= 1.7
33 34
BuildRequires: octave-devel
BuildRequires: python-devel
35
BuildRequires: scipy >= 0.8
36
BuildRequires: swig >= 3.0.7
37
BuildRequires: glue >= @MIN_GLUE_VERSION@
38 39
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
40
BuildRequires: python2-lal >= @MIN_LAL_VERSION@
41 42
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
43
BuildRequires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
44 45
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
46
BuildRequires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
47 48
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalburst-octave >= @MIN_LALBURST_VERSION@
49
BuildRequires: python2-lalburst >= @MIN_LALBURST_VERSION@
50 51
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: lalinspiral-octave >= @MIN_LALINSPIRAL_VERSION@
52
BuildRequires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
53 54
BuildRequires: lalpulsar-devel >= @MIN_LALPULSAR_VERSION@
BuildRequires: lalpulsar-octave >= @MIN_LALPULSAR_VERSION@
55
BuildRequires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
56 57
Requires: chealpix
Requires: gsl >= 1.15
58
Requires: hdf5
59
Requires: libmetaio
60 61 62 63 64 65
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar >= @MIN_LALPULSAR_VERSION@
66 67 68 69 70 71 72 73 74 75 76
Prefix: %{_prefix}

%description
The LSC Algorithm Inference Library for gravitational wave data analysis. This
package contains the shared-object libraries needed to run applications
that use the LAL Inference library.

%package devel
Summary: Files and documentation needed for compiling programs that use LAL Inference
Group: LAL
Requires: %{name} = %{version}
77
Requires: chealpix-devel >= 3.30.0
78 79
Requires: gsl-devel >= 1.15
Requires: libmetaio-devel
80 81 82 83 84 85
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-devel >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar-devel >= @MIN_LALPULSAR_VERSION@
86 87 88 89 90
%description devel
The LSC Algorithm Inference Library for gravitational wave data analysis. This
package contains files needed build applications that use the LAL Inference
library.

91 92
%package -n python2-%{name}
Summary: Python %{python2_version} Bindings for LALInference
93 94
Group: LAL
Requires: %{name} = %{version}
95
Requires: healpy >= 1.9.1
96
Requires: h5py
97
Requires: python-shapely
98
Requires: numpy >= 1.7
99
Requires: python
100
Requires: scipy >= 0.8
101
Requires: python-astropy >= 1.1.1
102
Requires: python-matplotlib >= 1.2.0
Leo Pound Singer's avatar
Leo Pound Singer committed
103
Requires: python-six
104
Requires: python-seaborn
105
Requires: glue >= @MIN_GLUE_VERSION@
106
Requires: ligo-gracedb
107
Requires: python-gwpy
108 109 110 111 112 113
Requires: python2-lal >= @MIN_LAL_VERSION@
Requires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: python2-lalburst >= @MIN_LALBURST_VERSION@
Requires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
114 115
Obsoletes: %{name}-python
Provides: %{name}-python
116
%description -n python2-%{name}
117
The LSC Algorithm Library for gravitational wave data analysis.
118
This package provides the Python %{python2_version} bindings for LALInference.
119 120 121 122 123

%package octave
Summary: Octave Bindings for LALInference
Group: LAL
Requires: %{name} = %{version}
124
Requires: octave
125 126 127 128 129 130
Requires: lal-octave >= @MIN_LAL_VERSION@
Requires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-octave >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-octave >= @MIN_LALINSPIRAL_VERSION@
Requires: lalpulsar-octave >= @MIN_LALPULSAR_VERSION@
131 132 133 134
%description octave
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Octave bindings for LALInference.

135
%prep
Adam Mercer's avatar
Adam Mercer committed
136
%setup -q -n %{name}-%{version}%{?nightly:-%{nightly}}
137 138

%build
139
%configure --disable-gcc-flags --enable-swig --enable-openmp
Adam Mercer's avatar
Adam Mercer committed
140
%{__make} %{?_smp_mflags} V=1
141

142
%check
143
%{__make} %{?_smp_mflags} V=1 VERBOSE=1 check
144

145
%install
146
%make_install
Adam Mercer's avatar
Adam Mercer committed
147
find $RPM_BUILD_ROOT%{_libdir} -name '*.la' -delete
148 149 150 151 152 153 154 155 156

%post
ldconfig

%postun
ldconfig

%clean
[ ${RPM_BUILD_ROOT} != "/" ] && rm -Rf ${RPM_BUILD_ROOT}
Adam Mercer's avatar
Adam Mercer committed
157
rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
158 159 160

%files
%defattr(-,root,root)
161
%license COPYING
162 163 164 165 166 167 168
%{_bindir}/lalinference_bench
%{_bindir}/lalinference_burst
%{_bindir}/lalinference_datadump
%{_bindir}/lalinference_injectedlike
%{_bindir}/lalinference_nest
%{_bindir}/lalinference_version
%{_bindir}/lalinference_mpi_wrapper
169
%{_datarootdir}/lalinference/*
170
%{_libdir}/*.so.*
171 172 173 174
%{_sysconfdir}/*

%files devel
%defattr(-,root,root)
175
%license COPYING
176
%{_includedir}/lal
177
%{_libdir}/*.a
178
%{_libdir}/*.so
179
%{_libdir}/pkgconfig/*
180

181
%files -n python2-%{name}
182
%defattr(-,root,root)
183
%license COPYING
184
%{_bindir}/cbcBayes*
Adam Mercer's avatar
Adam Mercer committed
185
%{_bindir}/imrtgr_*
186 187 188 189 190 191 192 193 194 195
%{_bindir}/lalinference_burst_pp_pipe
%{_bindir}/lalinference_coherence_test
%{_bindir}/lalinference_compute_roq_weights
%{_bindir}/lalinference_merge_posteriors
%{_bindir}/lalinference_multi_pipe
%{_bindir}/lalinference_nest2pos
%{_bindir}/lalinference_pipe
%{_bindir}/lalinference_pp_pipe
%{_bindir}/lalinference_review_test
%{_bindir}/lalinference_tiger_pipe
196
%{_bindir}/rapidpe_*
197
%{python2_sitearch}/*
198 199 200

%files octave
%defattr(-,root,root)
201
%license COPYING
202
%{_prefix}/lib*/octave/*/site/oct/*/lalinference.oct*
203 204 205

# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
206 207 208
* Mon Feb 25 2019 Adam Mercer <adam.mercer@ligo.org> 1.10.2-1
- ER14 release

209 210 211
* Tue Jan 22 2019 Adam Mercer <adam.mercer@ligo.org> 1.10.1-1
- Fix spin2 prior

212 213 214
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 1.10.0-1
- Pre O3 release

215 216 217
* Thu Jul 27 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.4-1
- bayestar_plot_volume: work around broken fonts in SL7

218 219 220
* Wed Jul 26 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.3-1
- BAYESTAR and sky map post-processing updates

221 222 223 224
* Thu Mar 16 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.2-1
- lalinference.io.fits: remove some redundant keys on reading
- lalinference.io.fits: fix writing single-column sky maps

225 226 227 228 229 230 231 232 233
* Sat Feb 18 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.1-1
- Do not use $(..._la_LIBADD) to link against external libraries
- Track version info API change
- Fix to weights calculation so that posterior samples are now drawn correctly
- Fix incorrect axes limits for Mollweide sky maps
- Drop code for reading past EOF of named pipe
- Fix incorrect reordering of IDL-compatible sky maps
- Tune default max distance for volume rendering plots

234 235 236
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.0-1
- O2 release

237 238 239 240
* Thu Dec 15 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.2-1
- Be more emphatic about switching matplotlib backend
- Prevent trying to build python3 packages when unsupported

241 242 243 244
* Fri Dec 09 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.1-1
- Explicitly set no-op Matplotlib backend
- Set matplotlib backend to no-op

245 246 247
* Mon Sep 26 2016 Adam Mercer <adam.mercer@ligo.org> 1.8.0-1
- ER10 release

248 249 250
* Thu Jun 23 2016 Adam Mercer <adam.mercer@ligo.org> 1.7.0-1
- ER9 release

251 252
* Fri Mar 25 2016 Adam Mercer <adam.mercer@ligo.org> 1.6.0-1
- Pre O2 packaging test release