Maintenance will be performed on git.ligo.org, chat.ligo.org, containers.ligo.org, and docs.ligo.org starting 2 March 2020 at approximately 8am MST. It is expected to take around 10 minutes and will include a short period of downtime towards the end of the maintenance window. Please direct any comments, concerns, or questions to computing-help@igwn.org.

Commit 00afe130 authored by Adam Mercer's avatar Adam Mercer

Merge branch 'pre-o3-release' into 'master'

Pre O3 Release

See merge request !463
parents 8f662b43 349dead4
Pipeline #31861 passed with stages
in 28 minutes and 12 seconds
AC_PREREQ([2.63])
AC_INIT([LALSuite],[6.48.1],[lal-discuss@ligo.org])
AC_INIT([LALSuite],[6.49],[lal-discuss@ligo.org])
AC_CONFIG_SRCDIR([configure.ac])
AC_CONFIG_AUX_DIR([gnuscripts])
AC_CONFIG_MACRO_DIR([gnuscripts])
......
AC_PREREQ([2.63])
AC_INIT([LAL],[6.18.0.1],[lal-discuss@ligo.org])
AC_INIT([LAL],[6.19.0],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h src/LALConfig.h])
AC_CONFIG_SRCDIR([src/std/LALStdio.h])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -88,9 +88,9 @@ LALSUITE_DISTCHECK_CONFIGURE_FLAGS
# then increment age.
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT],[14])
AC_SUBST([LIBCURRENT],[15])
AC_SUBST([LIBREVISION],[0])
AC_SUBST([LIBAGE],[0])
AC_SUBST([LIBAGE],[1])
AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
# set library api info - liblalsupport
......@@ -107,7 +107,7 @@ AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
# then increment age.
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT_SUPPORT],[11])
AC_SUBST([LIBCURRENT_SUPPORT],[12])
AC_SUBST([LIBREVISION_SUPPORT],[0])
AC_SUBST([LIBAGE_SUPPORT],[0])
AC_SUBST([LIBVERSION_SUPPORT],[${LIBCURRENT_SUPPORT}:${LIBREVISION_SUPPORT}:${LIBAGE_SUPPORT}])
......
lal (6.19.0-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 14:58:14 -0700
lal (6.18.0-1) unstable; urgency=low
* LAL 6.18.0
......
......@@ -37,6 +37,8 @@ Requires: fftw
Requires: gsl
Requires: hdf5
Requires: less
Obsoletes: python-pylal < 0.13.2-1
Provides: python-pylal = 0.13.2-1
Prefix: %{_prefix}
%description
......@@ -59,9 +61,6 @@ as well as the documentation for the library.
%package -n python2-%{name}
Summary: Python %{python2_version} bindings for LAL
Group: LAL
Provides: %{name}-python
Obsoletes: %{name}-python < 6.18.0-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: python
Requires: python-dateutil
......@@ -70,6 +69,8 @@ Requires: scipy
Requires: python-six
Requires: python2-ligo-segments
Requires: glue >= @MIN_GLUE_VERSION@
Obsoletes: %{name}-python
Provides: %{name}-python
%description -n python2-%{name}
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python %{python2_version} bindings.
......@@ -135,6 +136,9 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 6.19.0-1
- Pre O3 release
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 6.18.0-1
- O2 release
......
AC_PREREQ([2.63])
AC_INIT([LALApps],[6.21.0.1],[lal-discuss@ligo.org])
AC_INIT([LALApps],[6.22.0],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h])
AC_CONFIG_SRCDIR([src/lalapps/lalapps.c])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -60,14 +60,14 @@ AM_INIT_AUTOMAKE([ \
])
# version requirements
MIN_LAL_VERSION="6.18.0"
MIN_LALFRAME_VERSION="1.4.3"
MIN_LALMETAIO_VERSION="1.3.1"
MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LALBURST_VERSION="1.4.4"
MIN_LALINSPIRAL_VERSION="1.7.7"
MIN_LALPULSAR_VERSION="1.16.0"
MIN_LALINFERENCE_VERSION="1.9.0"
MIN_LAL_VERSION="6.19.0"
MIN_LALFRAME_VERSION="1.4.0"
MIN_LALMETAIO_VERSION="1.4.0"
MIN_LALSIMULATION_VERSION="1.8.0"
MIN_LALBURST_VERSION="1.5.0"
MIN_LALINSPIRAL_VERSION="1.8.0"
MIN_LALPULSAR_VERSION="1.17.0"
MIN_LALINFERENCE_VERSION="1.10.0"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALFRAME_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
......
lalapps (6.22.0-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 22:33:54 -0700
lalapps (6.21.0-1) unstable; urgency=low
* LALApps 6.21.0
......
......@@ -67,9 +67,17 @@ Depends: ${misc:Depends},
python-lalpulsar (>= @MIN_LALPULSAR_VERSION@~),
lalinference (>= @MIN_LALINFERENCE_VERSION@~),
python-lalinference (>= @MIN_LALINFERENCE_VERSION@~)
Breaks: lalinference-python (<< 1.94.1-1~)
Provides: python-bayestar-localization, python-bayestar
Conflicts: python-bayestar-localization, python-bayestar
Replaces: python-bayestar-localization, python-bayestar, pylal (<< 0.13.1)
Replaces: python-bayestar-localization,
python-bayestar,
pylal (<< 0.13.1),
lalstochastic,
lalstochastic-dev,
lalstochastic-python,
lalstochastic-python3,
lalstochastic-octave
Description: LSC Algorithm Library Applications
The LSC Algorithm Library Applications for gravitational wave data analysis.
This package contains applications that are built on tools in the
......
......@@ -59,7 +59,7 @@ Requires: lalframe >= @MIN_LALFRAME_VERSION@
Requires: python2-lalframe >= @MIN_LALFRAME_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: python2-lalburst >= @MIN_LALBURST_VERSION@
......@@ -70,6 +70,41 @@ Requires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
Requires: lalinference >= @MIN_LALINFERENCE_VERSION@
Requires: python2-lalinference >= @MIN_LALINFERENCE_VERSION@
Requires: skyarea
Obsoletes: lalxml < 1.2.5-1
Obsoletes: lalxml-debuginfo < 1.2.5-1
Obsoletes: lalxml-devel < 1.2.5-1
Obsoletes: lalxml-python < 1.2.5-1
Obsoletes: lalxml-python3 < 1.2.5-1
Obsoletes: lalxml-octave < 1.2.5-1
Obsoletes: laldetchar < 0.3.6-1
Obsoletes: laldetchar-debuginfo < 0.3.6-1
Obsoletes: laldetchar-devel < 0.3.6-1
Obsoletes: laldetchar-python < 0.3.6-1
Obsoletes: laldetchar-octave < 0.3.6-1
Obsoletes: lalstochastic < 1.1.21-1
Obsoletes: lalstochastic-debuginfo < 1.1.21-1
Obsoletes: lalstochastic-devel < 1.1.21-1
Obsoletes: lalstochastic-python < 1.1.21-1
Obsoletes: lalstochastic-python3 < 1.1.21-1
Obsoletes: lalstochastic-octave < 1.1.21-1
Provides: lalxml = 1.2.5-1
Provides: lalxml-debuginfo = 1.2.5-1
Provides: lalxml-devel = 1.2.5-1
Provides: lalxml-python = 1.2.5-1
Provides: lalxml-python3 = 1.2.5-1
Provides: lalxml-octave = 1.2.5-1
Provides: laldetchar = 0.3.6-1
Provides: laldetchar-debuginfo = 0.3.6-1
Provides: laldetchar-devel = 0.3.6-1
Provides: laldetchar-python = 0.3.6-1
Provides: laldetchar-octave = 0.3.6-1
Provides: lalstochastic = 1.1.21-1
Provides: lalstochastic-debuginfo = 1.1.21-1
Provides: lalstochastic-devel = 1.1.21-1
Provides: lalstochastic-python = 1.1.21-1
Provides: lalstochastic-python3 = 1.1.21-1
Provides: lalstochastic-octave = 1.1.21-1
Prefix: %{_prefix}
%description
......@@ -111,6 +146,9 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 6.22.0-1
- Pre O3 release
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 6.21.0-1
- O2 release
......
AC_PREREQ([2.63])
AC_INIT([LALBurst],[1.4.4.1],[lal-discuss@ligo.org])
AC_INIT([LALBurst],[1.5.0],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h src/LALBurstConfig.h])
AC_CONFIG_SRCDIR([src/EPSearch.c])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -36,9 +36,9 @@ AM_INIT_AUTOMAKE([ \
])
# version requirements
MIN_LAL_VERSION="6.18.0"
MIN_LALMETAIO_VERSION="1.3.1"
MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LAL_VERSION="6.19.0"
MIN_LALMETAIO_VERSION="1.4.0"
MIN_LALSIMULATION_VERSION="1.8.0"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
AC_SUBST([MIN_LALSIMULATION_VERSION])
......@@ -64,8 +64,8 @@ LALSUITE_DISTCHECK_CONFIGURE_FLAGS
# then increment age.
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT],[5])
AC_SUBST([LIBREVISION],[2])
AC_SUBST([LIBCURRENT],[6])
AC_SUBST([LIBREVISION],[0])
AC_SUBST([LIBAGE],[0])
AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
......
lalburst (1.5.0-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 16:17:07 -0700
lalburst (1.4.4-1) unstable; urgency=low
* LALBurst 1.4.4
......
......@@ -43,7 +43,7 @@ Depends: ${misc:Depends},
zlib1g,
lal (>= @MIN_LAL_VERSION@~),
lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
lalsimulation (>= @MIN_LALSIMULATION_VERSION@)
lalsimulation (>= @MIN_LALSIMULATION_VERSION@~)
Description: LSC Algorithm Library Burst
The LSC Algorithm Burst Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -59,7 +59,7 @@ Depends: ${misc:Depends},
zlib1g,
lal-dev (>= @MIN_LAL_VERSION@~),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (= ${binary:Version})
Description: LSC Algorithm Library Burst Developers
The LSC Algorithm Burst Library for gravitational wave data analysis.
......@@ -85,7 +85,7 @@ Depends: ${misc:Depends},
${shlibs:Depends},
python-lal (>= @MIN_LAL_VERSION@~),
python-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (= ${binary:Version}),
python-scipy,
python-glue
......@@ -112,7 +112,7 @@ Depends: ${misc:Depends},
${shlibs:Depends},
python3-lal (>= @MIN_LAL_VERSION@~),
python3-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (= ${binary:Version}),
python3-scipy,
python3-glue
......@@ -127,7 +127,7 @@ Depends: ${misc:Depends},
octave,
lal-octave (>= @MIN_LAL_VERSION@~),
lalmetaio-octave (>= @MIN_LALMETAIO_VERSION@~),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (= ${binary:Version})
Description: Octave bindings for LALBurst
The LSC Algorithm Burst Library for gravitational wave data analysis.
......
......@@ -64,9 +64,6 @@ library.
%package -n python2-%{name}
Summary: Python %{python2_version} Bindings for LALBurst
Group: LAL
Provides: %{name}-python
Obsoletes: %{name}-python < 1.4.4-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: numpy
Requires: python
......@@ -75,6 +72,8 @@ Requires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: scipy
Requires: glue
Obsoletes: %{name}-python
Provides: %{name}-python
%description -n python2-%{name}
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python %{python2_version} bindings for LALBurst.
......@@ -142,6 +141,9 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 1.5.0-1
- Pre O3 release
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 1.4.4-1
- O2 release
......
AC_PREREQ([2.63])
AC_INIT([LALFrame],[1.4.3.1],[lal-discuss@ligo.org])
AC_INIT([LALFrame],[1.4.4],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h src/LALFrameConfig.h])
AC_CONFIG_SRCDIR([src/LALFrameIO.c])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -37,7 +37,7 @@ AM_INIT_AUTOMAKE([ \
])
# version requirements
MIN_LAL_VERSION="6.18.0"
MIN_LAL_VERSION="6.19.0"
MIN_FRAMECPPC_VERSION="2.5.5"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_FRAMECPPC_VERSION])
......@@ -64,7 +64,7 @@ LALSUITE_DISTCHECK_CONFIGURE_FLAGS
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT],[10])
AC_SUBST([LIBREVISION],[2])
AC_SUBST([LIBREVISION],[3])
AC_SUBST([LIBAGE],[0])
AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
......
lalframe (1.4.4-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 15:13:42 -0700
lalframe (1.4.3-1) unstable; urgency=low
* LALFrame 1.4.3
......
......@@ -52,13 +52,12 @@ library.
%package -n python2-%{name}
Summary: Python %{python2_version} Bindings for LALFrame
Group: LAL
Provides: %{name}-python
Obsoletes: %{name}-python < 1.4.3-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: numpy
Requires: python
Requires: python2-lal >= @MIN_LAL_VERSION@
Obsoletes: %{name}-python
Provides: %{name}-python
%description -n python2-%{name}
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python %{python2_version} bindings for LALFrame.
......@@ -126,6 +125,9 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 1.4.4-1
- Pre O3 release
* Tue Feb 07 2017 Adam Mercer <adam.mercer@ligo.org> 1.4.3-1
- O2 release
......
......@@ -79,8 +79,16 @@ python/lalinference/bayestar/sky_map.so
python/lalinference/git_version.py
python/lalinference/lalinference.py
python/lalinference_average_skymaps
python/lalinference_burst_pp_pipe
python/lalinference_coherence_test
python/lalinference_compute_roq_weights
python/lalinference_merge_posteriors
python/lalinference_multi_pipe
python/lalinference_nest2pos
python/lalinference_pipe
python/lalinference_pp_pipe
python/lalinference_review_test
python/lalinference_tiger_pipe
python/rapidpe_calculate_overlap
python/rapidpe_compute_intrinsic_fisher
python/rapidpe_compute_intrinsic_grid
......@@ -97,8 +105,8 @@ src/git_version
src/lalinference_bench
src/lalinference_burst
src/lalinference_datadump
src/lalinference_nest
src/lalinference_injectedlike
src/lalinference_nest
src/lalinference_version
src/stamp-h1
src/stamp-h2
......
AC_PREREQ([2.63])
AC_INIT([LALInference],[1.9.4.1],[lal-discuss@ligo.org])
AC_INIT([LALInference],[1.10.0],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h src/LALInferenceConfig.h])
AC_CONFIG_SRCDIR([src/LALInference.h])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -47,21 +47,21 @@ AM_INIT_AUTOMAKE([ \
# version requirements
MIN_GLUE_VERSION="1.54.1"
MIN_LAL_VERSION="6.18.0"
MIN_LALMETAIO_VERSION="1.3.1"
MIN_LALFRAME_VERSION="1.4.3"
MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LALINSPIRAL_VERSION="1.7.7"
MIN_LALPULSAR_VERSION="1.16.0"
MIN_LALBURST_VERSION="1.4.4"
MIN_LAL_VERSION="6.19.0"
MIN_LALMETAIO_VERSION="1.4.0"
MIN_LALFRAME_VERSION="1.4.0"
MIN_LALSIMULATION_VERSION="1.8.0"
MIN_LALBURST_VERSION="1.5.0"
MIN_LALINSPIRAL_VERSION="1.8.0"
MIN_LALPULSAR_VERSION="1.17.0"
AC_SUBST([MIN_GLUE_VERSION])
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
AC_SUBST([MIN_LALFRAME_VERSION])
AC_SUBST([MIN_LALSIMULATION_VERSION])
AC_SUBST([MIN_LALBURST_VERSION])
AC_SUBST([MIN_LALINSPIRAL_VERSION])
AC_SUBST([MIN_LALPULSAR_VERSION])
AC_SUBST([MIN_LALBURST_VERSION])
AC_CANONICAL_HOST
......@@ -84,9 +84,9 @@ LALSUITE_DISTCHECK_CONFIGURE_FLAGS
# then increment age.
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT],[14])
AC_SUBST([LIBCURRENT],[15])
AC_SUBST([LIBREVISION],[0])
AC_SUBST([LIBAGE],[1])
AC_SUBST([LIBAGE],[0])
AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
# nightly build
......
lalinference (1.10.0-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 16:44:49 -0700
lalinference (1.9.4-1) unstable; urgency=low
* bayestar_plot_volume: work around broken fonts in SL7
......
......@@ -125,8 +125,8 @@ Depends:
python-lalinspiral (>= @MIN_LALINSPIRAL_VERSION@~),
python-lalpulsar (>= @MIN_LALPULSAR_VERSION@~),
lalinference (= ${binary:Version})
Replaces: lalapps (<< 6.14.0-1), lalinference-python (<< 1.9.4.1-1~)
Breaks: lalapps (<< 6.14.0-1), lalinference-python (<< 1.9.4.1-1~)
Replaces: lalapps (<< 6.21.0.1-1), lalinference-python (<< 1.9.4.1-1~)
Breaks: lalapps (<< 6.21.0.1-1), lalinference-python (<< 1.9.4.1-1~)
Description: Python bindings for LALInference
The LSC Algorithm Inference Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Inference library.
......
etc/*
usr/bin//lalinference_mpi_wrapper
usr/bin/lalinference_bench
usr/bin/lalinference_burst
usr/bin/lalinference_datadump
usr/bin/lalinference_injectedlike
usr/bin/lalinference_nest
usr/bin/lalinference_burst
usr/bin/lalinference_bench
usr/bin/lalinference_version
usr/lib/*/*.so.*
usr/share/lalinference/*.csv
......
../../gnuscripts/debian/pkg-python.install
\ No newline at end of file
usr/bin/bayestar_*
usr/bin/cbcBayes*
usr/bin/imrtgr_*
usr/bin/lalinference_average_skymaps
usr/bin/lalinference_burst_pp_pipe
usr/bin/lalinference_coherence_test
usr/bin/lalinference_compute_roq_weights
usr/bin/lalinference_merge_posteriors
usr/bin/lalinference_multi_pipe
usr/bin/lalinference_nest2pos
usr/bin/lalinference_pipe
usr/bin/lalinference_pp_pipe
usr/bin/lalinference_review_test
usr/bin/lalinference_tiger_pipe
usr/bin/rapidpe_*
usr/lib/python2*
......@@ -90,9 +90,6 @@ library.
%package -n python2-%{name}
Summary: Python %{python2_version} Bindings for LALInference
Group: LAL
Provides: %{name}-python
Obsoletes: %{name}-python < 1.9.4-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: healpy >= 1.9.1
Requires: h5py
......@@ -112,6 +109,8 @@ Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: python2-lalburst >= @MIN_LALBURST_VERSION@
Requires: python2-lalinspiral >= @MIN_LALINSPIRAL_VERSION@
Requires: python2-lalpulsar >= @MIN_LALPULSAR_VERSION@
Obsoletes: %{name}-python
Provides: %{name}-python
%description -n python2-%{name}
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python %{python2_version} bindings for LALInference.
......@@ -158,7 +157,13 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
%files
%defattr(-,root,root)
%license COPYING
%{_bindir}/lalinference_*
%{_bindir}/lalinference_bench
%{_bindir}/lalinference_burst
%{_bindir}/lalinference_datadump
%{_bindir}/lalinference_injectedlike
%{_bindir}/lalinference_nest
%{_bindir}/lalinference_version
%{_bindir}/lalinference_mpi_wrapper
%{_datarootdir}/lalinference/*
%{_libdir}/*.so.*
%{_sysconfdir}/*
......@@ -175,9 +180,20 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
%defattr(-,root,root)
%license COPYING
%{_bindir}/bayestar_*
%{_bindir}/cbcBayes*
%{_bindir}/imrtgr_*
%{_bindir}/lalinference_average_skymaps
%{_bindir}/lalinference_burst_pp_pipe
%{_bindir}/lalinference_coherence_test
%{_bindir}/lalinference_compute_roq_weights
%{_bindir}/lalinference_merge_posteriors
%{_bindir}/lalinference_multi_pipe
%{_bindir}/lalinference_nest2pos
%{_bindir}/lalinference_pipe
%{_bindir}/lalinference_pp_pipe
%{_bindir}/lalinference_review_test
%{_bindir}/lalinference_tiger_pipe
%{_bindir}/rapidpe_*
%{_bindir}/cbcBayes*
%{python2_sitearch}/*
%files octave
......@@ -187,6 +203,9 @@ rm -Rf ${RPM_BUILD_DIR}/%{name}-%{version}%{?nightly:-%{nightly}}
# dates should be formatted using: 'date +"%a %b %d %Y"'
%changelog
* Thu Sep 13 2018 Adam Mercer <adam.mercer@ligo.org> 1.10.0-1
- Pre O3 release
* Thu Jul 27 2017 Adam Mercer <adam.mercer@ligo.org> 1.9.4-1
- bayestar_plot_volume: work around broken fonts in SL7
......
AC_PREREQ([2.63])
AC_INIT([LALInspiral],[1.7.7.1],[lal-discuss@ligo.org])
AC_INIT([LALInspiral],[1.8.0],[lal-discuss@ligo.org])
AC_CONFIG_HEADERS([src/config.h src/LALInspiralConfig.h])
AC_CONFIG_SRCDIR([src/LALInspiral.h])
AC_CONFIG_AUX_DIR([gnuscripts])
......@@ -37,10 +37,10 @@ AM_INIT_AUTOMAKE([ \
])
# version requirements
MIN_LAL_VERSION="6.18.0"
MIN_LALFRAME_VERSION="1.4.3"
MIN_LALMETAIO_VERSION="1.3.1"
MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LAL_VERSION="6.19.0"
MIN_LALFRAME_VERSION="1.4.0"
MIN_LALMETAIO_VERSION="1.4.0"
MIN_LALSIMULATION_VERSION="1.8.0"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALFRAME_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
......@@ -67,9 +67,9 @@ LALSUITE_DISTCHECK_CONFIGURE_FLAGS
# then increment age.
# 6. if any interfaces have been removed since the last public release,
# then set age to 0.
AC_SUBST([LIBCURRENT],[11])
AC_SUBST([LIBREVISION],[2])
AC_SUBST([LIBAGE],[1])
AC_SUBST([LIBCURRENT],[12])
AC_SUBST([LIBREVISION],[0])
AC_SUBST([LIBAGE],[0])
AC_SUBST([LIBVERSION],[${LIBCURRENT}:${LIBREVISION}:${LIBAGE}])
# nightly build
......
lalinspiral (1.8.0-1) unstable; urgency=low
* Pre O3 release
-- Adam Mercer <adam.mercer@ligo.org> Thu, 13 Sep 2018 16:28:47 -0700
lalinspiral (1.7.7-1) unstable; urgency=low
* LALInspiral 1.7.7
......
......@@ -70,9 +70,6 @@ library.
%package -n python2-%{name}
Summary: Python bindings for LALInspiral
Group: LAL
Provides: %{name}-python
Obsoletes: %{name}-python < 1.7.7-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: numpy
Requires: python
......@@ -82,6 +79,8 @@ Requires: python2-lalframe >= @MIN_LALFRAME_VERSION@