Commit 024d1c40 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinspiral requires libmetaio

Original: 0c684cb7c10edd3acf11bc31d31fb4c03fa93f08
parent 5d66ab27
......@@ -103,6 +103,15 @@ AC_CHECK_LIB([gsl],[gsl_strerror],,[AC_MSG_ERROR([could not find the gsl library
# check for gsl headers
AC_CHECK_HEADERS([gsl/gsl_errno.h],,[AC_MSG_ERROR([could not find the gsl/gsl_errno.h header])])
# metaio
PKG_CHECK_MODULES([METAIO],[libmetaio],[true],[false])
CPPFLAGS="$CPPFLAGS $METAIO_CFLAGS"
LIBS="$LIBS $METAIO_LIBS"
AC_CHECK_LIB([metaio],[MetaioOpen],,[AC_MSG_ERROR([could not find the metaio library])])
# check for libmetaio headers
AC_CHECK_HEADERS([metaio.h],,[AC_MSG_ERROR([could not find the metaio.h header])])
# check for lal
LALSUITE_CHECK_LIB([LAL],[lal],[6.3.2.2],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSUPPORT],[lalsupport],[6.3.2.2],[LALOpenDataFile],[lal/FileIO.h])
......
......@@ -2,12 +2,12 @@ Source: lalinspiral
Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 5), autotools-dev, automake, m4, zlib1g-dev, lal-dev (>= 6.4), lal (>= 6.4), lalmetaio-dev (>= 1.0), lalmetaio (>= 1.0), pkg-config, python
Build-Depends: debhelper (>= 5), autotools-dev, automake, m4, zlib1g-dev, lal-dev (>= 6.4), lal (>= 6.4), lalmetaio-dev (>= 1.0), lalmetaio (>= 1.0), libmetaio-dev (>= 8.2), libmetaio1 (>= 8.2), pkg-config, python
Standards-Version: 3.7.2
Package: lalinspiral
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g, lal (>= 6.4), lalmetaio (>= 1.0)
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g, lal (>= 6.4), lalmetaio (>= 1.0), libmetaio1 (>= 8.2)
Description: LSC Algorithm Library Inspiral
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -15,7 +15,7 @@ Description: LSC Algorithm Library Inspiral
Package: lalinspiral-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g, lal-dev (>= 6.4), lalmetaio-dev (>= 1.0)
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g, lal-dev (>= 6.4), lalmetaio-dev (>= 1.0), libmetaio-dev (>= 8.2)
Description: LSC Algorithm Library Inspiral Developers
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......
......@@ -7,5 +7,5 @@ Name: LALInspiral
Description: LAL Inspiral Library Support
Version: @VERSION@
Requires: lal lalmetaio
Libs: -L${libdir} -llalinspiral @GSL_LIBS@
Cflags: -I${includedir} @GSL_CFLAGS@
Libs: -L${libdir} -llalinspiral @GSL_LIBS@ @METAIO_LIBS@
Cflags: -I${includedir} @GSL_CFLAGS@ @METAIO_CFLAGS@
......@@ -11,7 +11,7 @@ Source: %{name}-%{version}.tar.gz
URL: http://www.lsc-group.phys.uwm.edu/lal
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Requires: lal lalmetaio
Requires: lal metaio lalmetaio
Prefix: %{_prefix}
%description
......@@ -23,7 +23,7 @@ that use the LAL Inspiral library.
Summary: Files and documentation needed for compiling programs that use LAL Inspiral
Group: LAL
Requires: %{name} = %{version}
Requires: lal-devel lalmetaio-devel
Requires: lal-devel libmetaio-devel lalmetaio-devel
%description devel
The LSC Algorithm Inspiral Library for gravitational wave data analysis. This
package contains files needed build applications that use the LAL Inspiral
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment