Commit 05ea8239 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinference: add missing dependencies

Original: 9f59894d80606c4955c0783e3c63a2f608374b57
parent f8a03351
......@@ -12,8 +12,27 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig, python-devel, octave-devel
Requires: chealpix, healpy, gsl >= 1.15, libmetaio
BuildRequires: swig, python-devel, octave-devel, chealpix-devel, gsl-devel
BuildRequires: libmetaio-devel, libxml2-devel, numpy
BuildRequires: lal-devel >= 6.14.0
BuildRequires: lal-python >= 6.14.0
BuildRequires: lal-octave >= 6.14.0
BuildRequires: lalmetaio-devel >= 1.2.0
BuildRequires: lalmetaio-python >= 1.2.0
BuildRequires: lalmetaio-octave >= 1.2.0
BuildRequires: lalxml-devel >= 1.1.0
BuildRequires: lalxml-python >= 1.1.0
BuildRequires: lalxml-octave >= 1.1.0
BuildRequires: lalsimulation-devel >= 1.3.0
BuildRequires: lalsimulation-python >= 1.3.0
BuildRequires: lalsimulation-octave >= 1.3.0
BuildRequires: lalinspiral-devel >= 1.6.0
BuildRequires: lalinspiral-python >= 1.6.0
BuildRequires: lalinspiral-octave >= 1.6.0
BuildRequires: lalpulsar-devel >= 1.11.0
BuildRequires: lalpulsar-python >= 1.11.0
BuildRequires: lalpulsar-octave >= 1.11.0
Requires: chealpix, healpy, gsl >= 1.15, libmetaio, libxml2
Requires: lal >= 6.14.0
Requires: lalmetaio >= 1.2.0
Requires: lalxml >= 1.1.0
......@@ -31,7 +50,7 @@ that use the LAL Inference library.
Summary: Files and documentation needed for compiling programs that use LAL Inference
Group: LAL
Requires: %{name} = %{version}
Requires: chealpix-devel, gsl-devel >= 1.15, libmetaio-devel
Requires: chealpix-devel, gsl-devel >= 1.15, libmetaio-devel, libxml2-devel
Requires: lal-devel >= 6.14.0
Requires: lalmetaio-devel >= 1.2.0
Requires: lalxml-devel >= 1.1.0
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment