Commit 0c99e815 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinference: bump version requirements

(cherry picked from commit 5d9de563e1b1d1f37c2278a1dd1843911d4e3f57)
Original: cb4aebf3ea3a6fe99ddd7516ff046e8eebbe619d
parent b142d4f0
......@@ -175,13 +175,13 @@ if test "$lalxml" = "true"; then
fi
# check for lal libraries and headers
LALSUITE_CHECK_LIB([LAL],[6.11.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.11.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.1.0],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LAL],[6.12.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.12.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.2.0],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LALFrame],[1.1.0],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_LIB([LALSimulation],[1.0.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALSimulation],[1.1.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALInspiral],[1.5.0],[LALInspiralParameterCalc],[lal/LALInspiral.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.8.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.9.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[1.1.5],[XLALXMLFilePrintElements],[lal/LALXML.h])
......
......@@ -6,15 +6,15 @@ Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
libchealpix-dev,
zlib1g-dev, libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2),
swig (>= 2.0.11~), octave3.2-headers, python-numpy (>= 1.3),
lal-dev (>= 6.11.0~), lal-python (>= 6.11.0~),
lal-octave (>= 6.11.0~), lalframe-dev (>= 1.1.0~),
lal-dev (>= 6.12.0~), lal-python (>= 6.12.0~),
lal-octave (>= 6.12.0~), lalframe-dev (>= 1.1.0~),
lalframe-python (>= 1.1.0~), lalframe-octave (>= 1.1.0~),
lalmetaio-dev (>= 1.1.0), lalmetaio-python (>= 1.1.0),
lalmetaio-octave (>= 1.1.0), lalsimulation-dev (>= 1.0.0~),
lalsimulation-python (>= 1.0.0~), lalsimulation-octave (>= 1.0.0~),
lalmetaio-dev (>= 1.2.0), lalmetaio-python (>= 1.2.0),
lalmetaio-octave (>= 1.2.0), lalsimulation-dev (>= 1.1.0~),
lalsimulation-python (>= 1.1.0~), lalsimulation-octave (>= 1.1.0~),
lalinspiral-dev (>= 1.5.0), lalinspiral-python (>= 1.5.0),
lalinspiral-octave (>= 1.5.0), lalpulsar-dev (>= 1.8.0~),
lalpulsar-python (>= 1.8.0~), lalpulsar-octave (>= 1.8.0~)
lalinspiral-octave (>= 1.5.0), lalpulsar-dev (>= 1.9.0~),
lalpulsar-python (>= 1.8.0~), lalpulsar-octave (>= 1.9.0~)
X-Python-Version: >= 2.6
Standards-Version: 3.8.6
......@@ -23,9 +23,9 @@ Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libchealpix0, python-healpy,
libgsl0 (>= 1.9) | libgsl0ldbl (>= 1.10), libmetaio1 (>= 8.2),
lal (>= 6.11.0~), lalframe (>= 1.1.0~), lalmetaio (>= 1.1.0),
lalsimulation (>= 1.0.0~), lalinspiral (>= 1.5.0),
lalpulsar (>= 1.8.0~)
lal (>= 6.12.0~), lalframe (>= 1.1.0~), lalmetaio (>= 1.2.0),
lalsimulation (>= 1.1.0~), lalinspiral (>= 1.5.0),
lalpulsar (>= 1.9.0~)
Description: LSC Algorithm Library Inference
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -35,10 +35,10 @@ Package: lalinference-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libchealpix-dev,
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.11.0~),
lalframe-dev (>= 1.1.0~), lalmetaio-dev (>= 1.1.0),
lalsimulation-dev (>= 1.0.0~), lalinspiral-dev (>= 1.5.0),
lalpulsar-dev (>= 1.8.0~), lalinference (= ${binary:Version})
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.12.0~),
lalframe-dev (>= 1.1.0~), lalmetaio-dev (>= 1.2.0),
lalsimulation-dev (>= 1.1.0~), lalinspiral-dev (>= 1.5.0),
lalpulsar-dev (>= 1.9.0~), lalinference (= ${binary:Version})
Description: LSC Algorithm Library Inference Developers
The LSC Algorithm Inference Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......@@ -47,17 +47,17 @@ Description: LSC Algorithm Library Inference Developers
Package: lalinference-python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, python-numpy,
lalinference (= ${binary:Version}), lal-python (>= 6.11.0~),
lalframe-python (>= 1.1.0~), lalmetaio-python (>= 1.1.0),
lalsimulation-python (>= 1.0.0~), lalinspiral-python (>= 0.7.0),
lalpulsar-python (>= 1.8.0~)
lalinference (= ${binary:Version}), lal-python (>= 6.12.0~),
lalframe-python (>= 1.1.0~), lalmetaio-python (>= 1.2.0),
lalsimulation-python (>= 1.1.0~), lalinspiral-python (>= 1.5.0),
lalpulsar-python (>= 1.9.0~)
Description: Python bindings for LALInference
Package: lalinference-octave
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, octave,
lalinference (= ${binary:Version}), lal-octave (>= 6.11.0~),
lalframe-octave (>= 1.1.0~), lalmetaio-octave (>= 1.1.0),
lalsimulation-octave (>= 1.0.0~), lalinspiral-octave (>= 0.7.0),
lalpulsar-octave (>= 1.8.0~)
lalinference (= ${binary:Version}), lal-octave (>= 6.12.0~),
lalframe-octave (>= 1.1.0~), lalmetaio-octave (>= 1.2.0),
lalsimulation-octave (>= 1.1.0~), lalinspiral-octave (>= 1.5.0),
lalpulsar-octave (>= 1.9.0~)
Description: Octave bindings for LALInference
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment