Commit 0ca2fe5e authored by Adam Mercer's avatar Adam Mercer
Browse files

lal: add missing dependencies on hdf5

Original: 47c92c97060041773cd449d9378fb256991703a2
parent f972af7e
......@@ -4,14 +4,14 @@ Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev, zlib1g-dev,
libgsl0-dev (>= 1.9), libfftw3-dev, swig (>= 2.0.11~),
octave3.2-headers | liboctave-dev, python-numpy (>= 1.3), bc
octave3.2-headers | liboctave-dev, python-numpy (>= 1.3), bc, libhdf5-dev
X-Python-Version: >= 2.7
Standards-Version: 3.8.6
Package: lal
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g, ${python:Depends}
libgsl0 (>= 1.9) | libgsl0ldbl (>= 1.10), fftw3
libgsl0 (>= 1.9) | libgsl0ldbl (>= 1.10), fftw3, libhdf5-7
Description: LSC Algorithm Library
The LSC Algorithm Library for gravitational wave analysis.
This package contains the shared-object libraries needed to run applications
......@@ -20,7 +20,7 @@ Description: LSC Algorithm Library
Package: lal-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g-dev,
libgsl0-dev (>= 1.9), libfftw3-dev, lal (= ${binary:Version})
libgsl0-dev (>= 1.9), libfftw3-dev, libhdf5-dev, lal (= ${binary:Version})
Description: Files and documentation needed for compiling programs that use LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains files needed to build applications that use the LAL
......
......@@ -15,12 +15,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: bc
BuildRequires: fftw-devel
BuildRequires: gsl-devel
BuildRequires: hdf5-devel
BuildRequires: numpy
BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: swig
Requires: fftw
Requires: gsl
Requires: hdf5
Prefix: %{_prefix}
%description
......@@ -34,6 +36,7 @@ Group: LAL
Requires: %{name} = %{version}
Requires: fftw-devel
Requires: gsl-devel
Requires: hdf5-devel
%description devel
The LSC Algorithm Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL library
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment