Verified Commit 11e166e4 authored by Soichiro Morisaki's avatar Soichiro Morisaki Committed by Adam Mercer

lalinference/debian/control.in, lalinference/lalinference.spec.in and...

lalinference/debian/control.in, lalinference/lalinference.spec.in and wheel/setup.py.in: add gwdatafind and remove python-seaborn
parent 14f19dba
......@@ -14,12 +14,13 @@ Build-Depends: debhelper (>= 9),
pkg-config (>= 0.18.0),
python-all-dev,
python-astropy (>= 1.1.1),
python-gwdatafind,
python-gwpy,
python-h5py,
python-healpy (>= 1.9.1),
python-matplotlib (>= 1.2.0),
python-numpy (>= 1.7),
python-scipy (>= 0.8),
python-seaborn,
python-shapely,
python-pytest,
swig (>= 3.0.7),
......@@ -110,11 +111,11 @@ Depends:
${python:Depends},
${shlibs:Depends},
python-astropy (>= 1.1.1),
python-gwdatafind,
python-h5py,
python-matplotlib (>= 1.2.0),
python-pkg-resources,
python-scipy (>= 0.8),
python-seaborn,
python-shapely,
python-six,
python-glue (>= @MIN_GLUE_VERSION@),
......
......@@ -34,6 +34,8 @@ BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: scipy >= 0.8
BuildRequires: swig >= 3.0.7
BuildRequires: python2-gwdatafind
BuildRequires: python2-gwpy
BuildRequires: glue >= @MIN_GLUE_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
......@@ -99,12 +101,12 @@ Requires: numpy >= 1.7
Requires: python
Requires: scipy >= 0.8
Requires: python-astropy >= 1.1.1
Requires: python2-gwdatafind
Requires: python-matplotlib >= 1.2.0
Requires: python-six
Requires: python-seaborn
Requires: glue >= @MIN_GLUE_VERSION@
Requires: ligo-gracedb
Requires: python-gwpy
Requires: python2-gwpy
Requires: python2-lal >= @MIN_LAL_VERSION@
Requires: python2-lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: python2-lalsimulation >= @MIN_LALSIMULATION_VERSION@
......
......@@ -171,6 +171,9 @@ setup(
.replace('.so', '')
.replace('/', '.'), [])
for filename in glob(PYTHONDIR + '/**/*.so')],
extras_require={
'lalinference': ['gwpy', 'gwdatafind']
},
install_requires=['lscsoft-glue', 'ligo-segments', 'matplotlib',
'numpy>=1.7', 'python-dateutil', 'scipy']
)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment