Commit 277e57af authored by Adam Mercer's avatar Adam Mercer
Browse files

lal: add dependency on python-six

Original: 5c1c1f4627e60680f5487c8f21371834469695aa
parent c03ba675
......@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
Build-Depends: debhelper (>= 9), pkg-config, dh-python, python-all-dev, python3-all-dev, zlib1g-dev,
libgsl-dev | libgsl0-dev (>= 1.9), libfftw3-dev, swig (>= 3.0.7),
liboctave-dev, python-numpy, python3-numpy, bc, libhdf5-dev, less
liboctave-dev, python-numpy, python3-numpy, bc, libhdf5-dev, less, python-six, python3-six
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
......@@ -31,7 +31,7 @@ Package: lal-python
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, lal (= ${binary:Version}),
${python:Depends}
${python:Depends}, python-six
Description: Python bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains Python bindings for the LAL library.
......@@ -40,7 +40,7 @@ Package: lal-python3
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, lal (= ${binary:Version}),
${python3:Depends}
${python3:Depends}, python3-six
Description: Python 3 bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains Python 3 bindings for the LAL library.
......
......@@ -20,6 +20,7 @@ BuildRequires: less
BuildRequires: numpy
BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: python-six
BuildRequires: swig
Requires: fftw
Requires: gsl
......@@ -50,6 +51,7 @@ Group: LAL
Requires: %{name} = %{version}
Requires: numpy
Requires: python
Requires: python-six
%description python
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python bindings.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment