Verified Commit 2d170055 authored by Duncan Macleod's avatar Duncan Macleod
Browse files

lal: added missing python-dateutil dependency

`lal.gpstime` has a module-level import of `dateutil`
parent e1863434
......@@ -17,11 +17,13 @@ Build-Depends: bc,
python-glue (>= @MIN_GLUE_VERSION@),
python-numpy,
python-six,
python-dateutil,
python3-all-dev,
python3-ligo-segments,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-numpy,
python3-six,
python3-dateutil,
swig (>= 3.0.7),
zlib1g-dev
X-Python-Version: >= 2.7
......@@ -73,6 +75,7 @@ Depends: ${misc:Depends},
python-ligo-segments,
python-glue (>= @MIN_GLUE_VERSION@),
python-six,
python-dateutil,
lal (= ${binary:Version})
Description: Python bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
......@@ -98,6 +101,7 @@ Depends: ${misc:Depends},
python3-ligo-segments,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-six,
python3-dateutil,
lal (= ${binary:Version})
Description: Python 3 bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
......
......@@ -25,6 +25,7 @@ BuildRequires: glue >= @MIN_GLUE_VERSION@
BuildRequires: gsl-devel
BuildRequires: hdf5-devel
BuildRequires: less
BuildRequires: python-dateutil
BuildRequires: numpy
BuildRequires: scipy
BuildRequires: octave-devel
......@@ -63,6 +64,7 @@ Obsoletes: %{name}-python < 6.18.0-2
Conflicts: %{name}-python
Requires: %{name} = %{version}
Requires: python
Requires: python-dateutil
Requires: numpy
Requires: scipy
Requires: python-six
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment