Commit 58c1df34 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalpulsar: set lal* version deps in configure

Original: ec6e2f889e6bfc950c9c8c48f56d8ffb9a3d4794
parent a8748a41
......@@ -14,6 +14,7 @@ AUTHORS
Makefile
Makefile.in
config.lt
debian/control
doxygen/autogen.dox
doxygen/doxygen.cfg
doxygen/doxygen_objdb_*.tmp
......
......@@ -7,6 +7,7 @@ AC_CONFIG_MACRO_DIR([gnuscripts])
AC_CONFIG_FILES([ \
Makefile \
debian/Makefile \
debian/control \
doxygen/Makefile \
doxygen/doxygen.cfg \
include/Makefile \
......@@ -33,6 +34,12 @@ AM_INIT_AUTOMAKE([ \
no-dist-gzip \
])
# version requirements
MIN_LAL_VERSION="6.16.1"
MIN_LALXML_VERSION="1.2.2"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALXML_VERSION])
AC_CANONICAL_HOST
LALSUITE_ARG_VAR
......@@ -180,16 +187,16 @@ if test "${boinc}" = "true" ; then
fi
# check for lal libraries and headers
LALSUITE_CHECK_LIB([LAL],[6.16.1],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LAL],[${MIN_LAL_VERSION}],[LALVersion],[lal/LALStdio.h])
# check that lal was built with BOINC support, if required
LALSUITE_CHECK_BOINC
# check for lalsupport, needed for test suite
LALSUITE_CHECK_LIB([LALSupport],[6.16.1],[XLALCacheImport],[lal/LALCache.h])
LALSUITE_CHECK_LIB([LALSupport],[${MIN_LAL_VERSION}],[XLALCacheImport],[lal/LALCache.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[1.2.2],[XLALXMLFilePrintElements],[lal/LALXML.h])
LALSUITE_CHECK_OPT_LIB([LALXML],[${MIN_LALXML_VERSION}],[XLALXMLFilePrintElements],[lal/LALXML.h])
# back to c mode
if test "${boinc}" = "true" ; then
......
......@@ -5,12 +5,14 @@ Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 9), pkg-config, dh-python, python-all-dev, python3-all-dev,
libgsl-dev | libgsl0-dev (>= 1.9), libfftw3-dev, libcfitsio3-dev, swig (>=2.0.11~), octave3.2-headers | liboctave-dev,
python-numpy, python3-numpy,
lal-dev (>= 6.16.1~),
lal-python (>= 6.16.1~), lal-python3 (>= 6.16.1~),
lal-octave (>= 6.16.1~),
lalxml-dev (>= 1.2.2~),
lalxml-python (>= 1.2.2~), lalxml-python3 (>= 1.2.2~),
lalxml-octave (>= 1.2.2~)
lal-dev (>= @MIN_LAL_VERSION@~),
lal-python (>= @MIN_LAL_VERSION@~),
lal-python3 (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
......@@ -18,8 +20,8 @@ Standards-Version: 3.9.8
Package: lalpulsar
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
lal (>= 6.16.1~),
lalxml (>= 1.2.2~)
lal (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~)
Description: LSC Algorithm Library Pulsar
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -30,8 +32,8 @@ Section: libdevel
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libgsl-dev | libgsl0-dev (>= 1.9),
libfftw3-dev, libcfitsio3-dev, lalpulsar (= ${binary:Version}),
lal-dev (>= 6.16.1~),
lalxml-dev (>= 1.2.2~),
lal-dev (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
Description: LSC Algorithm Library Pulsar Developers
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......@@ -42,8 +44,8 @@ Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
lalpulsar (= ${binary:Version}),
lal-python (>= 6.16.1~),
lalxml-python (>= 1.2.2~)
lal-python (>= @MIN_LAL_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~)
Description: Python bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Pulsar library.
......@@ -53,8 +55,8 @@ Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends},
lalpulsar (= ${binary:Version}),
lal-python3 (>= 6.16.1~),
lalxml-python3 (>= 1.2.2~)
lal-python3 (>= @MIN_LAL_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~)
Description: Python 3 bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Python 3 bindings for the LAL Pulsar library.
......@@ -63,8 +65,8 @@ Package: lalpulsar-octave
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, octave,
lalpulsar (= ${binary:Version}),
lal-octave (>= 6.16.1~),
lalxml (>= 1.2.2~)
lal-octave (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~)
Description: Octave bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Octave bindings for the LAL Pulsar library.
......@@ -19,17 +19,17 @@ BuildRequires: numpy
BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: swig
BuildRequires: lal-devel >= 6.16.1
BuildRequires: lal-python >= 6.16.1
BuildRequires: lal-octave >= 6.16.1
BuildRequires: lalxml-devel >= 1.2.2
BuildRequires: lalxml-python >= 1.2.2
BuildRequires: lalxml-octave >= 1.2.2
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
BuildRequires: lalxml-devel >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-octave >= @MIN_LALXML_VERSION@
Requires: cfitsio
Requires: fftw
Requires: gsl
Requires: lal >= 6.16.1
Requires: lalxml >= 1.2.2
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalxml >= @MIN_LALXML_VERSION@
Prefix: %{_prefix}
%description
......@@ -45,8 +45,8 @@ Requires: cfitsio-devel
Requires: fftw-devel
Requires: fftw-static
Requires: gsl-devel
Requires: lal-devel >= 6.16.1
Requires: lalxml-devel >= 1.2.2
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalxml-devel >= @MIN_LALXML_VERSION@
%description devel
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......@@ -58,8 +58,8 @@ Group: LAL
Requires: %{name} = %{version}
Requires: numpy
Requires: python
Requires: lal-python >= 6.16.1
Requires: lalxml-python >= 1.2.2
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalxml-python >= @MIN_LALXML_VERSION@
%description python
This package provides the Python bindings for LALPulsar.
......@@ -68,8 +68,8 @@ Summary: Octave bindings for LALPulsar
Group: LAL
Requires: %{name} = %{version}
Requires: octave
Requires: lal-octave >= 6.16.1
Requires: lalxml-octave >= 1.2.2
Requires: lal-octave >= @MIN_LAL_VERSION@
Requires: lalxml-octave >= @MIN_LALXML_VERSION@
%description octave
This package provides the Octave bindings for LALPulsar.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment