Commit 5f928e11 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinference: bump version requirements

(cherry picked from commit 9c087711aa10cab902ab3b167ea2102fb39d1943)
Original: d9748920a9187677a6531403d891e4d7e3879155
parent 61fa46fe
......@@ -147,13 +147,13 @@ if test "$lalxml" = "true"; then
fi
# check for lal libraries and headers
LALSUITE_CHECK_LIB([LAL],[6.9.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.9.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.0.5],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LALFrame],[1.0.7],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_LIB([LALSimulation],[0.6.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALInspiral],[1.4.1],[LALInspiralParameterCalc],[lal/LALInspiral.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.6.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
LALSUITE_CHECK_LIB([LAL],[6.10.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.10.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.1.0],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LALFrame],[1.0.10],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_LIB([LALSimulation],[0.7.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALInspiral],[1.5.0],[LALInspiralParameterCalc],[lal/LALInspiral.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.7.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[1.1.5],[XLALXMLFilePrintElements],[lal/LALXML.h])
......
......@@ -4,9 +4,9 @@ Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2),
lal-dev (>= 6.9.0), lalframe-dev (>= 1.0.7),
lalmetaio-dev (>= 1.0.5), lalsimulation-dev (>= 0.6.0),
lalinspiral-dev (>= 1.4.1), lalpulsar-dev (>= 1.6.0)
lal-dev (>= 6.10.0), lalframe-dev (>= 1.0.10),
lalmetaio-dev (>= 1.1.0), lalsimulation-dev (>= 0.7.0),
lalinspiral-dev (>= 1.5.0), lalpulsar-dev (>= 1.7.0)
X-Python-Version: >= 2.6
Standards-Version: 3.8.6
......@@ -14,9 +14,9 @@ Package: lalinference
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libgsl0 (>= 1.9) | libgsl0ldbl (>= 1.10), libmetaio1 (>= 8.2),
lal (>= 6.9.0), lalframe (>= 1.0.7), lalmetaio (>= 1.0.5),
lalsimulation (>= 0.6.0), lalinspiral (>= 1.4.1),
lalpulsar (>= 1.6.0)
lal (>= 6.10.0), lalframe (>= 1.0.10), lalmetaio (>= 1.1.0),
lalsimulation (>= 0.7.0), lalinspiral (>= 1.5.0),
lalpulsar (>= 1.7.0)
Description: LSC Algorithm Library Inference
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -25,10 +25,10 @@ Description: LSC Algorithm Library Inference
Package: lalinference-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.9.0),
lalframe-dev (>= 1.0.7), lalmetaio-dev (>= 1.0.5),
lalsimulation-dev (>= 0.6.0), lalinspiral-dev (>= 1.4.1),
lalpulsar-dev (>= 1.6.0), lalinference (= ${binary:Version})
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.10.0),
lalframe-dev (>= 1.0.10), lalmetaio-dev (>= 1.1.0),
lalsimulation-dev (>= 0.7.0), lalinspiral-dev (>= 1.5.0),
lalpulsar-dev (>= 1.7.0), lalinference (= ${binary:Version})
Description: LSC Algorithm Library Inference Developers
The LSC Algorithm Inference Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment