Commit 6c248591 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalpulsar: order dependencies alphabetically

Original: d945117824f482fd69d75da7e6a971b62fbb9d6d
parent 5bc06882
......@@ -2,24 +2,34 @@ Source: lalpulsar
Section: science
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 9), pkg-config, dh-python, python-all-dev, python3-all-dev,
libgsl-dev | libgsl0-dev (>= 1.9), libfftw3-dev, libcfitsio3-dev, swig (>= 3.0.7), liboctave-dev,
python-numpy, python3-numpy,
Build-Depends: debhelper (>= 9),
dh-python,
libcfitsio3-dev,
libfftw3-dev,
libgsl-dev | libgsl0-dev (>= 1.9),
liboctave-dev,
pkg-config,
python-all-dev,
python-numpy,
python3-all-dev,
python3-numpy,
swig (>= 3.0.7),
lal-dev (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~),
lal-python (>= @MIN_LAL_VERSION@~),
lal-python3 (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~)
lalxml-python3 (>= @MIN_LALXML_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
Package: lalpulsar
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
Depends: ${misc:Depends},
${shlibs:Depends},
lal (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~)
Description: LSC Algorithm Library Pulsar
......@@ -30,10 +40,14 @@ Description: LSC Algorithm Library Pulsar
Package: lalpulsar-dev
Section: libdevel
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libgsl-dev | libgsl0-dev (>= 1.9),
libfftw3-dev, libcfitsio3-dev, lalpulsar (= ${binary:Version}),
Depends: ${misc:Depends},
${shlibs:Depends},
libcfitsio3-dev,
libfftw3-dev,
libgsl-dev | libgsl0-dev (>= 1.9),
lal-dev (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: LSC Algorithm Library Pulsar Developers
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......@@ -42,10 +56,12 @@ Description: LSC Algorithm Library Pulsar Developers
Package: lalpulsar-python
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
lalpulsar (= ${binary:Version}),
Depends: ${misc:Depends},
${python:Depends},
${shlibs:Depends},
lal-python (>= @MIN_LAL_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~)
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Python bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Pulsar library.
......@@ -53,20 +69,24 @@ Description: Python bindings for LALPulsar.
Package: lalpulsar-python3
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends},
lalpulsar (= ${binary:Version}),
Depends: ${misc:Depends},
${python3:Depends},
${shlibs:Depends},
lal-python3 (>= @MIN_LAL_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~)
lalxml-python3 (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Python 3 bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Python 3 bindings for the LAL Pulsar library.
Package: lalpulsar-octave
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, octave,
lalpulsar (= ${binary:Version}),
Depends: ${misc:Depends},
${shlibs:Depends},
octave,
lal-octave (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~)
lalxml (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Octave bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains Octave bindings for the LAL Pulsar library.
......@@ -20,11 +20,11 @@ BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: swig
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalxml-devel >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-octave >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
Requires: cfitsio
Requires: fftw
Requires: gsl
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment