Commit 82d8ea87 authored by Adam Mercer's avatar Adam Mercer
Browse files

Merge branch 'missing-dependencies' into 'master'

Added missing python dependencies for lalburst and lalinspiral

See merge request !319
parents c93d28d0 c039c429
Pipeline #22816 passed with stages
in 32 minutes and 21 seconds
......@@ -26,7 +26,11 @@ Build-Depends: debhelper (>= 9),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@~),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~)
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
python-scipy,
python3-scipy,
python-glue,
python3-glue
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
......@@ -82,7 +86,9 @@ Depends: ${misc:Depends},
python-lal (>= @MIN_LAL_VERSION@~),
python-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@),
lalburst (= ${binary:Version})
lalburst (= ${binary:Version}),
python-scipy,
python-glue
Description: Python bindings for LALBurst
The LSC Algorithm Burst Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Burst library.
......@@ -107,7 +113,9 @@ Depends: ${misc:Depends},
python3-lal (>= @MIN_LAL_VERSION@~),
python3-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@),
lalburst (= ${binary:Version})
lalburst (= ${binary:Version}),
python3-scipy,
python3-glue
Description: Python 3 bindings foar LALBurst
The LSC Algorithm Burst Library for gravitational wave data analysis.
This package contains Python 3 bindings for the LAL Burst library.
......
......@@ -28,6 +28,8 @@ BuildRequires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
BuildRequires: scipy
BuildRequires: glue
Requires: gsl
Requires: libmetaio
Requires: lal >= @MIN_LAL_VERSION@
......@@ -63,6 +65,8 @@ Requires: python
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
Requires: scipy
Requires: glue
%description python
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python bindings for LALBurst.
......
......@@ -31,7 +31,9 @@ Build-Depends: debhelper (>= 9),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@~),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~)
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
python-glue,
python3-glue
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
......@@ -90,7 +92,8 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
python-lalburst,
python-lalframe (>= @MIN_LALFRAME_VERSION@~),
python-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~)
python-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
python-glue
Description: Python bindings for LALInspiral
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Inspiral library.
......@@ -117,7 +120,8 @@ Depends: ${misc:Depends},
python3-lalframe (>= @MIN_LALFRAME_VERSION@~),
python3-lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
python3-lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
lalinspiral (= ${binary:Version})
lalinspiral (= ${binary:Version}),
python3-glue
Description: Python 3 bindings for LALInspiral
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains Python 3 bindings for the LAL Inspiral library.
......
......@@ -31,6 +31,7 @@ BuildRequires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
BuildRequires: glue
Requires: gsl
Requires: libframe
Requires: libmetaio
......@@ -72,6 +73,7 @@ Requires: lalburst-python
Requires: lalframe-python >= @MIN_LALFRAME_VERSION@
Requires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
Requires: glue
%description python
This package provides the Python bindings for LALInspiral.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment