Commit 9449be87 authored by Adam Mercer's avatar Adam Mercer
Browse files

require python-2.6+

Original: 5659f260586b4bdbefbf2e00ad0d9226632bf9a9
parent 1a48d66f
......@@ -210,7 +210,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
AC_CHECK_PROGS([M4],[gm4 m4], m4)
AC_CHECK_PROGS([LATEX],[pdflatex latex],[echo])
AC_CHECK_PROGS([MKIND],[makeindex],[echo])
......
......@@ -179,7 +179,7 @@ AC_CHECK_PROGS([LATEX],[pdflatex latex],[echo])
AC_CHECK_PROGS([MKIND],[makeindex],[echo])
AC_CHECK_PROGS([DVIPS],[dvips],[echo])
AC_CHECK_PROGS([BIBTEX],[bibtex],[echo])
AM_PATH_PYTHON([2.4],,[:])
AM_PATH_PYTHON([2.6],,[:])
AM_CONDITIONAL([HAVE_PYTHON],[test "$PYTHON" != :])
# check for supported mac os x version
......
......@@ -91,7 +91,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -97,7 +97,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
AC_CHECK_PROGS([M4],[gm4 m4],[m4])
# check for supported mac os x version
......
......@@ -98,7 +98,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -100,7 +100,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -90,7 +90,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -100,7 +100,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -94,7 +94,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
AC_CHECK_PROGS([M4],[gm4 m4],[m4])
# check for supported mac os x version
......
......@@ -91,7 +91,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
......@@ -94,7 +94,7 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_SED
LT_INIT
AM_PATH_PYTHON([2.4],,[AC_MSG_ERROR([Python-2.4, or higher, is required])])
AM_PATH_PYTHON([2.6],,[AC_MSG_ERROR([Python-2.6, or higher, is required])])
# check for supported mac os x version
LALSUITE_OSX_VERSION_CHECK
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment