Commit 96904068 authored by Karl Wette's avatar Karl Wette
Browse files

Remove SWIG from build dependencies of LALSuite Debian/RPM packages

- no longer needed since SWIG sources are bundled with release tarballs
Original: b70c381d85766496148003df9ce263500d2c57b5
parent eb6474ae
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev, zlib1g-dev,
libgsl0-dev (>= 1.9), libfftw3-dev, swig (>= 2.0.11~),
libgsl0-dev (>= 1.9), libfftw3-dev,
octave3.2-headers, python-numpy (>= 1.3)
X-Python-Version: >= 2.6
Standards-Version: 3.8.6
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Jolien Creighton <jolien@uwm.edu>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl fftw
Prefix: %{_prefix}
......
......@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2),
swig (>= 2.0.11~), octave3.2-headers, lal-dev (>= 6.13.0~),
octave3.2-headers, lal-dev (>= 6.13.0~),
lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~),
lalmetaio-dev (>= 1.2.0~), lalmetaio-python (>= 1.2.0~),
lalmetaio-octave (>= 1.2.0~), lalsimulation-dev (>= 1.2.0~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl libmetaio lal lalmetaio lalsimulation
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7.0.0), pkg-config, python-all-dev,
libgsl0-dev (>= 1.9), libglib2.0-dev, swig (>= 2.0.11~),
libgsl0-dev (>= 1.9), libglib2.0-dev,
octave3.2-headers, lal-dev (>= 6.13.0~),
lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~),
lalmetaio-dev (>= 1.2.0~), lalmetaio-python (>= 1.2.0~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: http://www.lsc-group.phys.uwm.edu/lal
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl libframe libmetaio lal lalframe lalmetaio lalsimulation lalburst
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7.0.0), python-all-dev, pkg-config,
zlib1g-dev, libframe-dev (>= 8.0), swig (>= 2.0.11~),
zlib1g-dev, libframe-dev (>= 8.0),
octave3.2-headers, python-numpy (>= 1.3), lal-dev (>= 6.13.0~),
lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~)
X-Python-Version: >= 2.6
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: libframe lal
Prefix: %{_prefix}
......
......@@ -5,7 +5,7 @@ Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
libchealpix-dev,
zlib1g-dev, libgsl0-dev (>= 1.15), libmetaio-dev (>= 8.2),
swig (>= 2.0.11~), octave3.2-headers, python-numpy (>= 1.3),
octave3.2-headers, python-numpy (>= 1.3),
lal-dev (>= 6.13.0~), lal-python (>= 6.13.0~),
lal-octave (>= 6.13.0~), lalframe-dev (>= 1.2.0~),
lalframe-python (>= 1.2.0~), lalframe-octave (>= 1.2.0~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: chealpix healpy gsl >= 1.15 libmetaio lal lalmetaio lalsimulation lalinspiral lalpulsar
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), python-all-dev, pkg-config,
zlib1g-dev, libgsl0-dev (>= 1.9), swig (>= 2.0.11~), octave3.2-headers,
zlib1g-dev, libgsl0-dev (>= 1.9), octave3.2-headers,
python-numpy, libframe-dev (>= 8.0), libmetaio-dev (>= 8.2),
lal-dev (>= 6.13.0~), lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~),
lalframe-dev (>= 1.2.0~), lalframe-python (>= 1.2.0~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl libframe libmetaio lal lalframe lalmetaio lalsimulation
Prefix: %{_prefix}
......
......@@ -3,8 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libmetaio-dev (>= 8.2), swig (>= 2.0.11~),
octave3.2-headers,
zlib1g-dev, libmetaio-dev (>= 8.2), octave3.2-headers,
lal-dev (>= 6.13.0~), lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~)
X-Python-Version: >= 2.6
Standards-Version: 3.8.6
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: libmetaio lal
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
libgsl0-dev (>= 1.9), swig (>=2.0.11~), octave3.2-headers,
libgsl0-dev (>= 1.9), octave3.2-headers,
python-numpy (>= 1.3), lal-dev (>= 6.13.0~), lal-python (>= 6.13.0~),
lal-octave (>= 6.13.0~)
X-Python-Version: >= 2.6
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl lal
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libgsl0-dev (>= 1.9), swig (>= 2.0.11~), octave3.2-headers,
zlib1g-dev, libgsl0-dev (>= 1.9), octave3.2-headers,
python-numpy (>= 1.3), lal-dev (>= 6.13.0~), lal-python (>= 6.13.0~),
lal-octave (>= 6.13.0~)
X-Python-Version: >= 2.6
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: gsl lal
Prefix: %{_prefix}
......
......@@ -3,7 +3,7 @@ Section: lscsoft
Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libmetaio-dev (>= 8.2), swig (>= 2.0.11~),
zlib1g-dev, libmetaio-dev (>= 8.2),
octave3.2-headers, python-numpy (>= 1.3), lal-dev (>= 6.13.0~),
lal-python (>= 6.13.0~), lal-octave (>= 6.13.0~),
lalmetaio-dev (>= 1.2.0~), lalmetaio-python (>= 1.2.0~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.gz
URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig python-devel octave-devel
BuildRequires: python-devel octave-devel
Requires: libmetaio lal lalmetaio
Prefix: %{_prefix}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment