Commit 98f315de authored by Adam Mercer's avatar Adam Mercer
Browse files

lalsimulation: order dependencies alphabetically

Original: 7bb4a2cfc1f97a2ac5564853b01e2d4b91d982e4
parent 9ce13ce8
......@@ -2,20 +2,30 @@ Source: lalsimulation
Section: science
Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 9), help2man, pkg-config, dh-python, python-all-dev, python3-all-dev,
zlib1g-dev, libgsl-dev | libgsl0-dev (>= 1.9), swig (>= 3.0.7), liboctave-dev,
python-numpy, python3-numpy,
Build-Depends: debhelper (>= 9),
dh-python,
help2man,
libgsl-dev | libgsl0-dev (>= 1.9),
liboctave-dev,
pkg-config,
python-all-dev,
python-numpy,
python3-all-dev,
python3-numpy,
swig (>= 3.0.7),
zlib1g-dev,
lal-dev (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~),
lal-python (>= @MIN_LAL_VERSION@~),
lal-python3 (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~)
lal-python3 (>= @MIN_LAL_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
Package: lalsimulation
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
Depends: ${misc:Depends},
${shlibs:Depends},
lal (>= @MIN_LAL_VERSION@~)
Description: LSC Algorithm Library Simulation
The LSC Algorithm Simulation Library for gravitational wave data analysis.
......@@ -25,8 +35,10 @@ Description: LSC Algorithm Library Simulation
Package: lalsimulation-dev
Section: libdevel
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g-dev,
Depends: ${misc:Depends},
${shlibs:Depends},
libgsl-dev | libgsl0-dev (>= 1.9),
zlib1g-dev,
lal-dev (>= @MIN_LAL_VERSION@~),
lalsimulation (= ${binary:Version})
Description: LSC Algorithm Library Simulation Developers
......@@ -37,9 +49,11 @@ Description: LSC Algorithm Library Simulation Developers
Package: lalsimulation-python
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
lalsimulation (= ${binary:Version}),
lal-python (>= @MIN_LAL_VERSION@~)
Depends: ${misc:Depends},
${python:Depends},
${shlibs:Depends},
lal-python (>= @MIN_LAL_VERSION@~),
lalsimulation (= ${binary:Version})
Description: Python bindings for LALSimulation
The LSC Algorithm Simulation Library for gravitational wave data analysis.
This package contains Python bindings for the LAL Simulation library.
......@@ -47,18 +61,23 @@ Description: Python bindings for LALSimulation
Package: lalsimulation-python3
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends},
lalsimulation (= ${binary:Version}),
lal-python3 (>= @MIN_LAL_VERSION@~)
Depends:
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
lal-python3 (>= @MIN_LAL_VERSION@~),
lalsimulation (= ${binary:Version})
Description: Python 3 bindings for LALSimulation
The LSC Algorithm Simulation Library for gravitational wave data analysis.
This package contains Python 3 bindings for the LAL Simulation library.
Package: lalsimulation-octave
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, octave,
lalsimulation (= ${binary:Version}),
lal-octave (>= @MIN_LAL_VERSION@~)
Depends: ${misc:Depends},
${shlibs:Depends},
octave,
lal-octave (>= @MIN_LAL_VERSION@~),
lalsimulation (= ${binary:Version})
Description: Octave bindings for LALSimulation
The LSC Algorithm Simulation Library for gravitational wave data analysis.
This package contains Octave bindings for the LAL Simulation library.
......@@ -18,8 +18,8 @@ BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: swig
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
Requires: gsl
Requires: lal >= @MIN_LAL_VERSION@
Prefix: %{_prefix}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment