Commit 9ae81901 authored by Leo Pound Singer's avatar Leo Pound Singer Committed by Adam Mercer

debian: hack to prevent trying to build python3 packages when unsupported

We have to trick py3versions into returning an empty string by requiring
nonexistent Python versions.
Solution proposed by Steffen Grunewald.
(cherry picked from commit bc75722d28ecebb92ac27bdc010add2068c26cd6)
Original: 1d6b50216566f985852d3f7e52940c9d85409002
parent 93ad6b15
......@@ -27,7 +27,7 @@ Build-Depends: debhelper (>= 9), help2man, pkg-config, dh-python, python-all-dev
lalinference-python (>= @MIN_LALINFERENCE_VERSION@~),
bc
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
X-Python3-Version: <= 3.0
Standards-Version: 3.9.8
Package: lalapps
......
......@@ -18,7 +18,7 @@ Build-Depends: debhelper (>= 9), help2man, pkg-config, dh-python, python-all-dev
lalburst-python (>= @MIN_LALBURST_VERSION@~),
lalburst-octave (>= @MIN_LALBURST_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
X-Python3-Version: <= 3.0
Standards-Version: 3.9.8
Package: laldetchar
......
......@@ -35,7 +35,7 @@ Build-Depends: debhelper (>= 9), help2man, pkg-config, dh-python, python-all-dev
lalpulsar-python (>= @MIN_LALPULSAR_VERSION@~),
lalpulsar-octave (>= @MIN_LALPULSAR_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
X-Python3-Version: <= 3.0
Standards-Version: 3.9.8
Package: lalinference
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment