Commit b896b508 authored by Adam Mercer's avatar Adam Mercer
Browse files

lal: order dependencies alphabetically

Original: 7edf99d912bba9f94b3ad8568a3bdbf5a846f3b4
parent 506d522b
......@@ -2,16 +2,33 @@ Source: lal
Section: science
Priority: optional
Maintainer: Steffen Grunewald <steffen.grunewald@aei.mpg.de>
Build-Depends: debhelper (>= 9), pkg-config, dh-python, python-all-dev, python3-all-dev, zlib1g-dev,
libgsl-dev | libgsl0-dev (>= 1.9), libfftw3-dev, swig (>= 3.0.7),
liboctave-dev, python-numpy, python3-numpy, bc, libhdf5-dev, less, python-six, python3-six, python-glue, python3-glue
Build-Depends: bc,
debhelper (>= 9),
dh-python,
less,
libfftw3-dev, swig (>= 3.0.7),
libgsl-dev | libgsl0-dev (>= 1.9),
libhdf5-dev,
liboctave-dev,
pkg-config,
python-all-dev,
python-glue,
python-numpy,
python-six,
python3-all-dev,
python3-glue,
python3-numpy,
python3-six,
zlib1g-dev
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
Package: lal
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, less
Depends: ${misc:Depends},
${shlibs:Depends},
less
Description: LSC Algorithm Library
The LSC Algorithm Library for gravitational wave analysis.
This package contains the shared-object libraries needed to run applications
......@@ -20,8 +37,13 @@ Description: LSC Algorithm Library
Package: lal-dev
Section: libdevel
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g-dev,
libgsl-dev | libgsl0-dev (>= 1.9), libfftw3-dev, libhdf5-dev, lal (= ${binary:Version})
Depends: ${misc:Depends},
${shlibs:Depends},
libfftw3-dev,
libgsl-dev | libgsl0-dev (>= 1.9),
libhdf5-dev,
zlib1g-dev,
lal (= ${binary:Version})
Description: Files and documentation needed for compiling programs that use LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains files needed to build applications that use the LAL
......@@ -30,8 +52,12 @@ Description: Files and documentation needed for compiling programs that use LAL
Package: lal-python
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, lal (= ${binary:Version}),
${python:Depends}, python-six, python-glue
Depends: ${misc:Depends},
${python:Depends},
${shlibs:Depends},
lal (= ${binary:Version}),
python-glue,
python-six
Description: Python bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains Python bindings for the LAL library.
......@@ -39,15 +65,21 @@ Description: Python bindings for LAL
Package: lal-python3
Section: python
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, lal (= ${binary:Version}),
${python3:Depends}, python3-six, python3-glue
Depends: ${misc:Depends},
${python3:Depends},
${shlibs:Depends},
lal (= ${binary:Version}),
python3-glue,
python3-six
Description: Python 3 bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
This package contains Python 3 bindings for the LAL library.
Package: lal-octave
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, lal (= ${binary:Version}),
Depends: ${misc:Depends},
${shlibs:Depends},
lal (= ${binary:Version}),
octave
Description: Octave bindings for LAL
The LSC Algorithm Library for gravitational wave analysis.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment