Commit daf58c35 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinference: bump dependency versions

(cherry picked from commit 85581cac2c6462014ae7e447945c0cd99aa351f0)
Original: 1bbc51446fb14b6ce0796692c5fe63cd0ccbb355
parent 31f09a15
......@@ -136,16 +136,16 @@ if test "$lalxml" = "true"; then
fi
# check for lal libraries and headers
LALSUITE_CHECK_LIB([LAL],[6.7.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.7.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.0.4],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LALFrame],[1.0.5],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_LIB([LALSimulation],[0.3.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALInspiral],[1.3.0],[LALInspiralParameterCalc],[lal/LALInspiral.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.4.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
LALSUITE_CHECK_LIB([LAL],[6.8.0],[LALVersion],[lal/LALStdio.h])
LALSUITE_CHECK_LIB([LALSupport],[6.8.0],[LALOpenDataFile],[lal/FileIO.h])
LALSUITE_CHECK_LIB([LALMetaIO],[1.0.5],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_LIB([LALFrame],[1.0.7],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_LIB([LALSimulation],[0.5.0],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_LIB([LALInspiral],[1.4.0],[LALInspiralParameterCalc],[lal/LALInspiral.h])
LALSUITE_CHECK_LIB([LALPulsar],[1.5.0],[XLALComputeFaFb],[lal/ComputeFstat.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[1.1.3],[XLALXMLFilePrintElements],[lal/LALXML.h])
LALSUITE_CHECK_OPT_LIB([LALXML],[1.1.5],[XLALXMLFilePrintElements],[lal/LALXML.h])
# add gcc specific flags
LALSUITE_ADD_GCC_FLAGS
......
......@@ -4,9 +4,9 @@ Priority: optional
Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 7), pkg-config, python-all-dev,
zlib1g-dev, libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2),
lal-dev (>= 6.7.0), lalframe-dev (>= 1.0.5),
lalmetaio-dev (>= 1.0.4), lalsimulation-dev (>= 0.3.0),
lalinspiral-dev (>= 1.3.0), lalpulsar-dev (>= 1.3.0)
lal-dev (>= 6.8.0), lalframe-dev (>= 1.0.7),
lalmetaio-dev (>= 1.0.5), lalsimulation-dev (>= 0.5.0),
lalinspiral-dev (>= 1.4.0), lalpulsar-dev (>= 1.5.0)
X-Python-Version: >= 2.6
Standards-Version: 3.8.6
......@@ -14,9 +14,9 @@ Package: lalinference
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libgsl0 (>= 1.9) | libgsl0ldbl (>= 1.10), libmetaio1 (>= 8.2),
lal (>= 6.7.0), lalframe (>= 1.0.5), lalmetaio (>= 1.0.4),
lalsimulation (>= 0.3.0), lalinspiral (>= 1.3.0),
lalpulsar (>= 1.3.0)
lal (>= 6.8.0), lalframe (>= 1.0.7), lalmetaio (>= 1.0.5),
lalsimulation (>= 0.5.0), lalinspiral (>= 1.4.0),
lalpulsar (>= 1.5.0)
Description: LSC Algorithm Library Inference
The LSC Algorithm Inspiral Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -25,10 +25,10 @@ Description: LSC Algorithm Library Inference
Package: lalinference-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, zlib1g,
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.7.0),
lalframe-dev (>= 1.0.5), lalmetaio-dev (>= 1.0.4),
lalsimulation-dev (>= 0.3.0), lalinspiral-dev (>= 1.3.0),
lalpulsar-dev (>= 1.3.0), lalinference (= ${binary:Version})
libgsl0-dev (>= 1.9), libmetaio-dev (>= 8.2), lal-dev (>= 6.8.0),
lalframe-dev (>= 1.0.7), lalmetaio-dev (>= 1.0.5),
lalsimulation-dev (>= 0.5.0), lalinspiral-dev (>= 1.4.0),
lalpulsar-dev (>= 1.5.0), lalinference (= ${binary:Version})
Description: LSC Algorithm Library Inference Developers
The LSC Algorithm Inference Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment