Commit f8a03351 authored by Adam Mercer's avatar Adam Mercer
Browse files

lalinference: version spec file dependencies

Original: 799fa56dcef0b51275788699ee3fc4db1f5a9a96
parent 6be97c71
......@@ -13,7 +13,13 @@ URL: https://www.lsc-group.phys.uwm.edu/daswg/projects/lalsuite.html
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: swig, python-devel, octave-devel
Requires: chealpix, healpy, gsl >= 1.15, libmetaio, lal, lalmetaio, lalxml, lalsimulation, lalinspiral, lalpulsar
Requires: chealpix, healpy, gsl >= 1.15, libmetaio
Requires: lal >= 6.14.0
Requires: lalmetaio >= 1.2.0
Requires: lalxml >= 1.1.0
Requires: lalsimulation >= 1.3.0
Requires: lalinspiral >= 1.6.0
Requires: lalpulsar >= 1.11.0
Prefix: %{_prefix}
%description
......@@ -25,7 +31,13 @@ that use the LAL Inference library.
Summary: Files and documentation needed for compiling programs that use LAL Inference
Group: LAL
Requires: %{name} = %{version}
Requires: chealpix-devel, gsl-devel >= 1.15, libmetaio-devel, lal-devel, lalmetaio-devel, lalxml-devel, lalsimulation-devel, lalinspiral-devel, lalpulsar-devel
Requires: chealpix-devel, gsl-devel >= 1.15, libmetaio-devel
Requires: lal-devel >= 6.14.0
Requires: lalmetaio-devel >= 1.2.0
Requires: lalxml-devel >= 1.1.0
Requires: lalsimulation-devel >= 1.3.0
Requires: lalinspiral-devel >= 1.6.0
Requires: lalpulsar-devel >= 1.11.0
%description devel
The LSC Algorithm Inference Library for gravitational wave data analysis. This
package contains files needed build applications that use the LAL Inference
......@@ -35,7 +47,13 @@ library.
Summary: Python Bindings for LALInference
Group: LAL
Requires: %{name} = %{version}
Requires: python, numpy, lal-python, lalmetaio-python, lalxml-python, lalsimulation-python, lalinspiral-python, lalpulsar-python
Requires: python, numpy
Requires: lal-python >= 6.14.0
Requires: lalmetaio-python >= 1.2.0
Requires: lalxml-python >= 1.1.0
Requires: lalsimulation-python >= 1.3.0
Requires: lalinspiral-python >= 1.6.0
Requires: lalpulsar-python >= 1.11.0
%description python
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Python bindings for LALInference.
......@@ -44,7 +62,13 @@ This package provides the Python bindings for LALInference.
Summary: Octave Bindings for LALInference
Group: LAL
Requires: %{name} = %{version}
Requires: octave, lal-octave, lalmetaio-octave, lalxml-octave, lalsimulation-octave, lalinspiral-octave, lalpulsar-octave
Requires: octave
Requires: lal-octave >= 6.14.0
Requires: lalmetaio-octave >= 1.2.0
Requires: lalxml-octave >= 1.1.0
Requires: lalsimulation-octave >= 1.3.0
Requires: lalinspiral-octave >= 1.6.0
Requires: lalpulsar-octave >= 1.11.0
%description octave
The LSC Algorithm Library for gravitational wave data analysis.
This package provides the Octave bindings for LALInference.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment