Commit 369d026b authored by Adam Mercer's avatar Adam Mercer

lal{pulsar,inference,apps}: drop lalxml dependency

LALXML is no longer used, or needed
parent f87c4d6a
......@@ -104,7 +104,7 @@ level2:lalpulsar:
<<: *levelN-package
stage: level2
dependencies:
- level1:lalxml
- level0:lal
level2:lalstochastic:
<<: *levelN-package
......@@ -457,7 +457,6 @@ level2:rpm:lalpulsar:
stage: level2
dependencies:
- level0:rpm:lal
- level1:rpm:lalxml
level2:rpm:lalstochastic:
<<: *levelN-rpm-package
......@@ -483,7 +482,6 @@ level3:rpm:lalinference:
- level1:rpm:lalframe
- level1:rpm:lalmetaio
- level1:rpm:lalsimulation
- level1:rpm:lalxml
- level2:rpm:lalburst
- level2:rpm:lalinspiral
- level2:rpm:lalpulsar
......@@ -496,7 +494,6 @@ level4:rpm:lalapps:
- level1:rpm:lalframe
- level1:rpm:lalmetaio
- level1:rpm:lalsimulation
- level1:rpm:lalxml
- level2:rpm:lalburst
- level2:rpm:lalinspiral
- level2:rpm:lalpulsar
......
......@@ -63,7 +63,6 @@ AM_INIT_AUTOMAKE([ \
MIN_LAL_VERSION="6.18.0"
MIN_LALFRAME_VERSION="1.4.3"
MIN_LALMETAIO_VERSION="1.3.1"
MIN_LALXML_VERSION="1.2.4"
MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LALBURST_VERSION="1.4.4"
MIN_LALINSPIRAL_VERSION="1.7.7"
......@@ -73,7 +72,6 @@ MIN_LALSTOCHASTIC_VERSION="1.1.20"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALFRAME_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
AC_SUBST([MIN_LALXML_VERSION])
AC_SUBST([MIN_LALSIMULATION_VERSION])
AC_SUBST([MIN_LALBURST_VERSION])
AC_SUBST([MIN_LALINSPIRAL_VERSION])
......@@ -110,7 +108,6 @@ LALAPPS_ENABLE_GDS
LALSUITE_ENABLE_LALFRAME
LALSUITE_ENABLE_LALMETAIO
LALSUITE_ENABLE_LALXML
LALSUITE_ENABLE_LALSIMULATION
LALSUITE_ENABLE_LALBURST
LALSUITE_ENABLE_LALINSPIRAL
......@@ -300,28 +297,6 @@ if test "${metaio}" = "true"; then
fi
LALSUITE_ENABLE_MODULE([METAIO])
# check for libxml2
if test "$lalxml" = "true"; then
AC_SEARCH_LIBS([lzma_code],[lzma])
PKG_CHECK_MODULES([LIBXML2],[libxml-2.0 >= 2.6],[true],[false])
lal_pre_libxml2_LIBS="$LIBS"
LALSUITE_ADD_FLAGS([C],[],[${LIBXML2_LIBS}])
AC_SEARCH_LIBS([xmlInitParser],[xml2],,
[AC_MSG_WARN([cannot find the xml2 library])]
[lalxml="false"]
[LIBS="$lal_pre_libxml2_LIBS"])
fi
# check for libxml2 headers
if test "$lalxml" = "true"; then
lal_pre_libxml2_CPPFLAGS="$CPPFLAGS"
LALSUITE_ADD_FLAGS([C],[${LIBXML2_CFLAGS}],[])
AC_CHECK_HEADERS([libxml/tree.h],,
[AC_MSG_WARN([could not the libxml/tree.h header])]
[lalxml="false"]
[CPPFLAGS="$lal_pre_libxml2_CPPFLAGS"])
fi
# check for cfitsio
LALSUITE_USE_CFITSIO
......@@ -382,7 +357,6 @@ LALSUITE_CHECK_LIB([LAL],[${MIN_LAL_VERSION}],[XLALPerror],[lal/XLALError.h])
LALSUITE_CHECK_LIB([LALSupport],[${MIN_LAL_VERSION}],[XLALCacheImport],[lal/LALCache.h])
LALSUITE_CHECK_OPT_LIB([LALFrame],[${MIN_LALFRAME_VERSION}],[LALFrOpen],[lal/LALFrameL.h])
LALSUITE_CHECK_OPT_LIB([LALMetaIO],[${MIN_LALMETAIO_VERSION}],[XLALCreateMetaTableDir],[lal/LIGOLwXMLRead.h])
LALSUITE_CHECK_OPT_LIB([LALXML],[${MIN_LALXML_VERSION}],[XLALXMLFilePrintElements],[lal/LALXML.h])
LALSUITE_CHECK_OPT_LIB([LALSimulation],[${MIN_LALSIMULATION_VERSION}],[XLALSimDetectorStrainREAL8TimeSeries],[lal/LALSimulation.h])
LALSUITE_CHECK_OPT_LIB([LALBurst],[${MIN_LALBURST_VERSION}],[XLALEPSearch],[lal/EPSearch.h])
LALSUITE_CHECK_OPT_LIB([LALInspiral],[${MIN_LALINSPIRAL_VERSION}],[LALInspiralParameterCalc],[lal/LALInspiral.h])
......@@ -453,7 +427,6 @@ LALApps has now been successfully configured:
* MetaIO library support is $METAIO_ENABLE_VAL
* LALFrame library support is $LALFRAME_ENABLE_VAL
* LALMetaIO library support is $LALMETAIO_ENABLE_VAL
* LALXML library support is $LALXML_ENABLE_VAL
* LALSimulation library support is $LALSIMULATION_ENABLE_VAL
* LALBurst library support is $LALBURST_ENABLE_VAL
* LALInspiral library support is $LALINSPIRAL_ENABLE_VAL
......
......@@ -22,8 +22,6 @@ Build-Depends: bc,
lalframe-python (>= @MIN_LALFRAME_VERSION@~),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
lalburst-dev (>= @MIN_LALBURST_VERSION@~),
......@@ -58,8 +56,6 @@ Depends: ${misc:Depends},
lalframe-python (>= @MIN_LALFRAME_VERSION@~),
lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (>= @MIN_LALBURST_VERSION@~),
......
......@@ -28,8 +28,6 @@ BuildRequires: lalframe-devel >= @MIN_LALFRAME_VERSION@
BuildRequires: lalframe-python >= @MIN_LALFRAME_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalxml-devel >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
......@@ -58,8 +56,6 @@ Requires: lalframe >= @MIN_LALFRAME_VERSION@
Requires: lalframe-python >= @MIN_LALFRAME_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
Requires: lalxml >= @MIN_LALXML_VERSION@
Requires: lalxml-python >= @MIN_LALXML_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
......
......@@ -57,7 +57,6 @@ MIN_LALSIMULATION_VERSION="1.7.0"
MIN_LALINSPIRAL_VERSION="1.7.7"
MIN_LALPULSAR_VERSION="1.16.0"
MIN_LALBURST_VERSION="1.4.4"
MIN_LALXML_VERSION="1.2.4"
AC_SUBST([MIN_GLUE_VERSION])
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
......@@ -66,7 +65,6 @@ AC_SUBST([MIN_LALSIMULATION_VERSION])
AC_SUBST([MIN_LALINSPIRAL_VERSION])
AC_SUBST([MIN_LALPULSAR_VERSION])
AC_SUBST([MIN_LALBURST_VERSION])
AC_SUBST([MIN_LALXML_VERSION])
AC_CANONICAL_HOST
......@@ -106,7 +104,6 @@ LALSUITE_ENABLE_LALMETAIO
LALSUITE_ENABLE_LALINSPIRAL
LALSUITE_ENABLE_LALPULSAR
LALSUITE_ENABLE_LALBURST
LALSUITE_ENABLE_LALXML
# enable SWIG wrapping modules
LALSUITE_ENABLE_SWIG
......@@ -196,13 +193,6 @@ if test "${with_hdf5}" != "yes"; then
AC_MSG_ERROR([could not find the HDF5 library])
fi
if test "$lalxml" = "true"; then
# check for libxml2
PKG_CHECK_MODULES([LIBXML2],[libxml-2.0 >= 2.6],[true],[false])
LALSUITE_ADD_FLAGS([C],[${LIBXML2_CFLAGS}],[${LIBXML2_LIBS}])
AC_CHECK_LIB([xml2],[xmlInitParser],,[AC_MSG_WARN([cannot find the xml2 library])])
fi
# check for lal libraries and headers
LALSUITE_CHECK_LIB([LAL],[${MIN_LAL_VERSION}],[XLALPerror],[lal/XLALError.h])
LALSUITE_CHECK_LIB([LALSupport],[${MIN_LAL_VERSION}],[XLALCacheImport],[lal/LALCache.h])
......@@ -213,10 +203,6 @@ LALSUITE_CHECK_LIB([LALInspiral],[${MIN_LALINSPIRAL_VERSION}],[LALInspiralParame
LALSUITE_CHECK_LIB([LALPulsar],[${MIN_LALPULSAR_VERSION}],[XLALComputeFstat],[lal/ComputeFstat.h])
LALSUITE_CHECK_LIB([LALBurst],[${MIN_LALBURST_VERSION}],[XLALEPSearch],[lal/EPSearch.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[${MIN_LALXML_VERSION}],[XLALXMLFilePrintElements],[lal/LALXML.h])
dnl FIXME: This doesn't work in the top-level build, because it tries
dnl to compile and link against LAL itself, which will not have been built yet.
dnl
......@@ -272,7 +258,6 @@ AC_MSG_NOTICE([
LALInference has now been successfully configured:
* Python support is $PYTHON_ENABLE_VAL
* LALXML library support is $LALXML_ENABLE_VAL
* SWIG bindings for Octave are $SWIG_BUILD_OCTAVE_ENABLE_VAL
* SWIG bindings for Python are $SWIG_BUILD_PYTHON_ENABLE_VAL
* HEALPix is $HEALPIX_ENABLE_VAL
......
......@@ -33,9 +33,6 @@ Build-Depends: debhelper (>= 9),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
lalmetaio-octave (>= @MIN_LALMETAIO_VERSION@~),
lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@~),
lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
......@@ -60,7 +57,6 @@ Depends: ${misc:Depends},
lal (>= @MIN_LAL_VERSION@~),
lalframe (>= @MIN_LALFRAME_VERSION@~),
lalmetaio (>= @MIN_LALMETAIO_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~),
lalsimulation (>= @MIN_LALSIMULATION_VERSION@~),
lalburst (>= @MIN_LALBURST_VERSION@~),
lalinspiral (>= @MIN_LALINSPIRAL_VERSION@~),
......@@ -84,7 +80,6 @@ Depends: ${misc:Depends},
lal-dev (>= @MIN_LAL_VERSION@~),
lalframe-dev (>= @MIN_LALFRAME_VERSION@~),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalsimulation-dev (>= @MIN_LALSIMULATION_VERSION@~),
lalburst-dev (>= @MIN_LALBURST_VERSION@~),
lalinspiral-dev (>= @MIN_LALINSPIRAL_VERSION@~),
......@@ -115,7 +110,6 @@ Depends:
lal-python (>= @MIN_LAL_VERSION@~),
lalframe-python (>= @MIN_LALFRAME_VERSION@~),
lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalsimulation-python (>= @MIN_LALSIMULATION_VERSION@~),
lalburst-python (>= @MIN_LALBURST_VERSION@~),
lalinspiral-python (>= @MIN_LALINSPIRAL_VERSION@~),
......@@ -135,7 +129,6 @@ Depends: ${misc:Depends},
lal-octave (>= @MIN_LAL_VERSION@~),
lalframe-octave (>= @MIN_LALFRAME_VERSION@~),
lalmetaio-octave (>= @MIN_LALMETAIO_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~),
lalsimulation-octave (>= @MIN_LALSIMULATION_VERSION@~),
lalburst-octave (>= @MIN_LALBURST_VERSION@~),
lalinspiral-octave (>= @MIN_LALINSPIRAL_VERSION@~),
......
......@@ -22,7 +22,6 @@ BuildRequires: python-matplotlib >= 1.2.0
BuildRequires: python-shapely
BuildRequires: pytest
BuildRequires: libmetaio-devel
BuildRequires: libxml2-devel
BuildRequires: numpy >= 1.7
BuildRequires: octave-devel
BuildRequires: python-devel
......@@ -35,9 +34,6 @@ BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
BuildRequires: lalxml-devel >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-octave >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
......@@ -54,10 +50,8 @@ Requires: chealpix
Requires: gsl >= 1.15
Requires: hdf5
Requires: libmetaio
Requires: libxml2
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalmetaio >= @MIN_LALMETAIO_VERSION@
Requires: lalxml >= @MIN_LALXML_VERSION@
Requires: lalsimulation >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst >= @MIN_LALBURST_VERSION@
Requires: lalinspiral >= @MIN_LALINSPIRAL_VERSION@
......@@ -76,10 +70,8 @@ Requires: %{name} = %{version}
Requires: chealpix-devel >= 3.30.0
Requires: gsl-devel >= 1.15
Requires: libmetaio-devel
Requires: libxml2-devel
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
Requires: lalxml-devel >= @MIN_LALXML_VERSION@
Requires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-devel >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
......@@ -106,7 +98,6 @@ Requires: glue >= @MIN_GLUE_VERSION@
Requires: ligo-gracedb
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
Requires: lalxml-python >= @MIN_LALXML_VERSION@
Requires: lalsimulation-python >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-python >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-python >= @MIN_LALINSPIRAL_VERSION@
......@@ -122,7 +113,6 @@ Requires: %{name} = %{version}
Requires: octave
Requires: lal-octave >= @MIN_LAL_VERSION@
Requires: lalmetaio-octave >= @MIN_LALMETAIO_VERSION@
Requires: lalxml-octave >= @MIN_LALXML_VERSION@
Requires: lalsimulation-octave >= @MIN_LALSIMULATION_VERSION@
Requires: lalburst-octave >= @MIN_LALBURST_VERSION@
Requires: lalinspiral-octave >= @MIN_LALINSPIRAL_VERSION@
......
......@@ -38,9 +38,7 @@ AM_INIT_AUTOMAKE([ \
# version requirements
MIN_LAL_VERSION="6.18.0"
MIN_LALXML_VERSION="1.2.4"
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALXML_VERSION])
AC_CANONICAL_HOST
......@@ -151,13 +149,6 @@ AC_CHECK_LIB([fftw3],[fftw_execute_dft],,[AC_MSG_ERROR([could not find the fftw3
# check for fft headers
AC_CHECK_HEADERS([fftw3.h],,[AC_MSG_ERROR([could not find the fftw3.h header])])
if test "$lalxml" = "true"; then
# check for libxml2
PKG_CHECK_MODULES([LIBXML2],[libxml-2.0 >= 2.6],[true],[false])
LALSUITE_ADD_FLAGS([C],[${LIBXML2_CFLAGS}],[${LIBXML2_LIBS}])
AC_CHECK_LIB([xml2],[xmlInitParser],,[AC_MSG_WARN([cannot find the xml2 library])])
fi
# check for cfitsio
LALSUITE_USE_CFITSIO
......@@ -170,9 +161,6 @@ LALSUITE_CHECK_LIB([LAL],[${MIN_LAL_VERSION}],[XLALPerror],[lal/XLALError.h])
# check for lalsupport, needed for test suite
LALSUITE_CHECK_LIB([LALSupport],[${MIN_LAL_VERSION}],[XLALCacheImport],[lal/LALCache.h])
# check for lalxml
LALSUITE_CHECK_OPT_LIB([LALXML],[${MIN_LALXML_VERSION}],[XLALXMLFilePrintElements],[lal/LALXML.h])
# finish boinc checks, and restore compiler after lal library checks
LALSUITE_END_CHECK_BOINC
......@@ -207,7 +195,6 @@ AC_MSG_NOTICE([
LALPulsar has now been successfully configured:
* Python support is $PYTHON_ENABLE_VAL
* LALXML library support is $LALXML_ENABLE_VAL
* BOINC support is $BOINC_ENABLE_VAL
* CFITSIO library support is $CFITSIO_ENABLE_VAL
* SWIG bindings for Octave are $SWIG_BUILD_OCTAVE_ENABLE_VAL
......
......@@ -18,10 +18,6 @@ Build-Depends: debhelper (>= 9),
lal-octave (>= @MIN_LAL_VERSION@~),
lal-python (>= @MIN_LAL_VERSION@~),
lal-python3 (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalxml-octave (>= @MIN_LALXML_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~)
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Standards-Version: 3.9.8
......@@ -31,7 +27,6 @@ Architecture: any
Depends: ${misc:Depends},
${shlibs:Depends},
lal (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~)
Description: LSC Algorithm Library Pulsar
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains the shared-object libraries needed to run applications
......@@ -46,7 +41,6 @@ Depends: ${misc:Depends},
libfftw3-dev,
libgsl-dev | libgsl0-dev (>= 1.9),
lal-dev (>= @MIN_LAL_VERSION@~),
lalxml-dev (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: LSC Algorithm Library Pulsar Developers
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
......@@ -60,7 +54,6 @@ Depends: ${misc:Depends},
${python:Depends},
${shlibs:Depends},
lal-python (>= @MIN_LAL_VERSION@~),
lalxml-python (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Python bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
......@@ -73,7 +66,6 @@ Depends: ${misc:Depends},
${python3:Depends},
${shlibs:Depends},
lal-python3 (>= @MIN_LAL_VERSION@~),
lalxml-python3 (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Python 3 bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
......@@ -85,7 +77,6 @@ Depends: ${misc:Depends},
${shlibs:Depends},
octave,
lal-octave (>= @MIN_LAL_VERSION@~),
lalxml (>= @MIN_LALXML_VERSION@~),
lalpulsar (= ${binary:Version})
Description: Octave bindings for LALPulsar.
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
......
......@@ -23,14 +23,10 @@ BuildRequires: swig >= 3.0.7
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
BuildRequires: lalxml-devel >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-octave >= @MIN_LALXML_VERSION@
BuildRequires: lalxml-python >= @MIN_LALXML_VERSION@
Requires: cfitsio
Requires: fftw
Requires: gsl
Requires: lal >= @MIN_LAL_VERSION@
Requires: lalxml >= @MIN_LALXML_VERSION@
Prefix: %{_prefix}
%description
......@@ -47,7 +43,6 @@ Requires: fftw-devel
Requires: fftw-static
Requires: gsl-devel
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalxml-devel >= @MIN_LALXML_VERSION@
%description devel
The LSC Algorithm Pulsar Library for gravitational wave data analysis.
This package contains files needed build applications that use the LAL
......@@ -60,7 +55,6 @@ Requires: %{name} = %{version}
Requires: numpy
Requires: python
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalxml-python >= @MIN_LALXML_VERSION@
%description python
This package provides the Python bindings for LALPulsar.
......@@ -70,7 +64,6 @@ Group: LAL
Requires: %{name} = %{version}
Requires: octave
Requires: lal-octave >= @MIN_LAL_VERSION@
Requires: lalxml-octave >= @MIN_LALXML_VERSION@
%description octave
This package provides the Octave bindings for LALPulsar.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment