Commit bc9f98e4 authored by Adam Mercer's avatar Adam Mercer

lalinference: set glue version dep in configure

Original: 5c929ea3f2d4e6ac28d18310d08474529eb2f71f
parent 8fb2a044
......@@ -43,6 +43,7 @@ AM_INIT_AUTOMAKE([ \
])
# version requirements
MIN_GLUE_VERSION="1.49.1"
MIN_LAL_VERSION="6.17.0"
MIN_LALMETAIO_VERSION="1.3.0"
MIN_LALFRAME_VERSION="1.4.2"
......@@ -51,6 +52,7 @@ MIN_LALINSPIRAL_VERSION="1.7.6"
MIN_LALPULSAR_VERSION="1.15.0"
MIN_LALBURST_VERSION="1.4.3"
MIN_LALXML_VERSION="1.2.3"
AC_SUBST([MIN_GLUE_VERSION])
AC_SUBST([MIN_LAL_VERSION])
AC_SUBST([MIN_LALMETAIO_VERSION])
AC_SUBST([MIN_LALFRAME_VERSION])
......
......@@ -20,7 +20,7 @@ Build-Depends: debhelper (>= 9),
python-shapely,
swig (>= 3.0.7),
zlib1g-dev,
python-glue (>= 1.49.1~),
python-glue (>= @MIN_GLUE_VERSION@),
lal-dev (>= @MIN_LAL_VERSION@~),
lal-octave (>= @MIN_LAL_VERSION@~),
lal-python (>= @MIN_LAL_VERSION@~),
......@@ -105,7 +105,7 @@ Depends:
python-seaborn,
python-shapely,
python-six,
python-glue (>= 1.49.1~),
python-glue (>= @MIN_GLUE_VERSION@),
lal-python (>= @MIN_LAL_VERSION@~),
lalframe-python (>= @MIN_LALFRAME_VERSION@~),
lalmetaio-python (>= @MIN_LALMETAIO_VERSION@~),
......
......@@ -24,7 +24,7 @@ BuildRequires: octave-devel
BuildRequires: python-devel
BuildRequires: scipy
BuildRequires: swig
BuildRequires: glue >= 1.49.1
BuildRequires: glue >= @MIN_GLUE_VERSION@
BuildRequires: lal-devel >= @MIN_LAL_VERSION@
BuildRequires: lal-octave >= @MIN_LAL_VERSION@
BuildRequires: lal-python >= @MIN_LAL_VERSION@
......@@ -96,7 +96,7 @@ Requires: python
Requires: scipy
Requires: python-six
Requires: python-seaborn
Requires: glue >= 1.49.1
Requires: glue >= @MIN_GLUE_VERSION@
Requires: lal-python >= @MIN_LAL_VERSION@
Requires: lalmetaio-python >= @MIN_LALMETAIO_VERSION@
Requires: lalxml-python >= @MIN_LALXML_VERSION@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment