There will be maintenance performed on git.ligo.org, chat.ligo.org, containers.lig.org, and docs.ligo.org starting at 9am PDT on Tuesday 18th August 2020. There will be an extremely small period of downtime at the start of the maintenance window as various services are restarted. Please address any comments, questions, or concerns to computing-help@igwn.org.

Commit fcc124d3 authored by Leo Pound Singer's avatar Leo Pound Singer

Laldetchar depends on glib >= 2.14

This version introduced the fuction `g_sequence_new`.
parent 3494e18e
......@@ -135,7 +135,7 @@ LALSUITE_ENABLE_FAST_GSL
AC_CHECK_HEADERS([gsl/gsl_errno.h],,[AC_MSG_ERROR([could not find the gsl/gsl_errno.h header])])
# check for glib
PKG_CHECK_MODULES([GLIB],[glib-2.0],[true],[false])
PKG_CHECK_MODULES([GLIB],[glib-2.0 >= 2.14],[true],[false])
LALSUITE_ADD_FLAGS([C],[${GLIB_CFLAGS}],[${GLIB_LIBS}])
AC_CHECK_LIB([glib-2.0],[g_sequence_new],,[AC_MSG_ERROR([could not find the glib library])])
AC_CHECK_HEADERS([glib.h],,[AC_MSG_ERROR([could not find the glib.h header])])
......
......@@ -5,7 +5,7 @@ Maintainer: Adam Mercer <adam.mercer@ligo.org>
Build-Depends: debhelper (>= 9),
dh-python,
help2man,
libglib2.0-dev,
libglib2.0-dev (>= 2.14),
libgsl-dev | libgsl0-dev (>= 1.9),
liboctave-dev,
pkg-config,
......@@ -48,7 +48,7 @@ Section: libdevel
Architecture: any
Depends: ${misc:Depends},
${shlibs:Depends},
libglib2.0-dev,
libglib2.0-dev (>= 2.14),
libgsl-dev | libgsl0-dev (>= 1.9),
lal-dev (>= @MIN_LAL_VERSION@~),
lalmetaio-dev (>= @MIN_LALMETAIO_VERSION@~),
......
......@@ -12,7 +12,7 @@ Source: %{name}-%{version}.tar.xz
URL: http://wiki.ligo.org/DASWG/LALSuite
Packager: Adam Mercer <adam.mercer@ligo.org>
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: glib2-devel
BuildRequires: glib2-devel >= 2.14
BuildRequires: gsl-devel
BuildRequires: libmetaio-devel
BuildRequires: numpy
......@@ -50,7 +50,7 @@ that use the LAL DetChar library.
Summary: Files and documentation needed for compiling programs that use LAL DetChar
Group: LAL
Requires: %{name} = %{version}
Requires: glib2-devel
Requires: glib2-devel >= 2.14
Requires: gsl-devel
Requires: libmetaio-devel
Requires: lal-devel >= @MIN_LAL_VERSION@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment