Commit ed10937b authored by Leo Pound Singer's avatar Leo Pound Singer

Update requirements

parent ac852a27
Pipeline #56995 passed with stages
in 10 minutes and 37 seconds
......@@ -23,23 +23,23 @@ When you use pip to install `ligo.skymap` with pip, it will automatically
install the following required Python packages:
* `Astroplan <http://astroplan.readthedocs.io>`_
* Astropy_ ≥ 3.0
* `Numpy <http://www.numpy.org>`_ ≥ 1.13
* `Healpy <http://healpy.readthedocs.io>`_ ≥ 1.9.1
(note, considering a transition to
`astropy-healpix <http://astropy-healpix.readthedocs.io>`_,
which is easier to install)
* Astropy_ ≥ 3.1
* `astropy-healpix <https://astropy-healpix.readthedocs.io>`_
* `Healpy <http://healpy.readthedocs.io>`_
* `h5py <https://www.h5py.org>`_
* `LALSuite <https://pypi.python.org/pypi/lalsuite>`_
* `lscsoft-glue <https://pypi.org/project/lscsoft-glue/>`_
* `ligo-gracedb <https://pypi.org/project/ligo-gracedb/>`_
* `ligo-segments <https://pypi.org/project/ligo-segments/>`_
* `Matplotlib <https://matplotlib.org>`_ ≥ 2.1.0
* `NetworkX <https://networkx.github.io>`_
* `Numpy <http://www.numpy.org>`_ ≥ 1.14
* `Pillow <http://pillow.readthedocs.io>`_ ≥ 2.5.0
* `ptemcee <https://github.com/willvousden/ptemcee>`_
* `Reproject <https://reproject.readthedocs.io>`_ = 0.3.2
* `python-ligo-lw <https://pypi.org/project/python-ligo-lw/>`_
* `Reproject <https://reproject.readthedocs.io>`_ ≥ 0.3.2
* `Scipy <https://www.scipy.org>`_ ≥ 0.14
* `Seaborn <https://seaborn.pydata.org>`_ ≥ 0.8.0
* `Shapely <http://toblerity.org/shapely/>`_
* `tqdm <https://tqdm.github.io>`_
* `pytz <http://pytz.sourceforge.net>`_
......
astroplan
astropy-healpix>=0.3 # https://github.com/astropy/astropy-healpix/pull/106
astropy>=3.1
astropy-healpix>=0.3 # https://github.com/astropy/astropy-healpix/pull/106
healpy
h5py
lalsuite>=6.53
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment