Commit 6d465657 authored by Alexander Pace's avatar Alexander Pace

Merge branch 'remove-m2crypto' into 'master'

Removed m2crypto references

See merge request !9
parents 1ef6de1a 688e414c
Pipeline #33061 failed with stage
in 3 minutes and 17 seconds
......@@ -24,7 +24,6 @@ import libxml2
import getpass
import uuid
from optparse import *
from M2Crypto.SSL import Context
# pubsub import must come first because it overloads part of the
# StanzaProcessor class
......@@ -163,12 +162,6 @@ else:
class MyClient(Client):
def __init__(self, jid, password):
# we require a TLS connection
# Specify sslv3 to get around Sun Java SSL bug handling session ticket
# https://rt.phys.uwm.edu/Ticket/Display.html?id=1825
# http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6728126
# NOTE: This is no longer necessary after Openfire 3.7.
# (See update to RT ticket above.)
#t=TLSSettings(require=True,verify_peer=False, ctx=Context('sslv3'))
t=TLSSettings(require=True,verify_peer=False)
# setup client with provided connection information
......
......@@ -28,7 +28,6 @@ import uuid
import six.moves.configparser
from subprocess import Popen, PIPE
from optparse import *
from M2Crypto.SSL import Context
# pubsub import must come first because it overloads part of the
# StanzaProcessor class
......@@ -282,12 +281,6 @@ class LVAlertHandler(object):
class MyClient(Client):
def __init__(self, jid, password,actions, wait=True):
# we require a TLS connection
# Specify sslv3 to get around Sun Java SSL bug handling session ticket
# https://rt.phys.uwm.edu/Ticket/Display.html?id=1825
# http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6728126
# NOTE: This is no longer necessary after Openfire 3.7.
# (See update to RT ticket above.)
#t=TLSSettings(require=True,verify_peer=False, ctx=Context('sslv3'))
t=TLSSettings(require=True,verify_peer=False)
# setup client with provided connection information
......
......@@ -25,7 +25,6 @@ import libxml2
import getpass
import uuid
from optparse import OptionParser
from M2Crypto.SSL import Context
# pubsub import must come first because it overloads part of the
# StanzaProcessor class
......@@ -175,12 +174,6 @@ class MyClient(Client):
self.onStart = onStart
# we require a TLS connection
# Specify sslv3 to get around Sun Java SSL bug handling session ticket
# https://rt.phys.uwm.edu/Ticket/Display.html?id=1825
# http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6728126
# NOTE: This is no longer necessary after Openfire 3.7.
# (See update to RT ticket above.)
#t=TLSSettings(require=True,verify_peer=False, ctx=Context('sslv3'))
t=TLSSettings(require=True,verify_peer=False)
# setup client with provided connection information
......
Note that the dependencies for the python3-ligo-lvalert package is somewhat
different from the python-ligo-lvalert package because python3-m2crypto and
python3-pyxmpp do not exist. However, some basic functions of lvalert doesn't
different from the python-ligo-lvalert package because python3-pyxmpp does not
exist. However, some basic functions of lvalert doesn't
need them. Consider making them recommended rather than required dependencies.
The python3-libxml2 dependency exists in stretch.
......@@ -14,7 +14,7 @@ X-Python3-Version: >=3.4
Package: python2-ligo-lvalert
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-pyxmpp, python-libxml2, python-m2crypto, python-dnspython, python-ligo-common, python-sleekxmpp
Depends: ${misc:Depends}, ${python:Depends}, python-pyxmpp, python-libxml2, python-dnspython, python-ligo-common
Provides: ${python:Provides}
Description: LIGO-Virgo Alert Network - Python
The LIGO-Virgo Alert Network (LVAlert) is a prototype notification service
......
......@@ -37,7 +37,7 @@ setup(
# provides = ['ligo.lvalert'],
packages = find_packages(),
install_requires = ['sleekxmpp', 'M2Crypto', 'dnspython', 'numpy', 'six'],
install_requires = ['sleekxmpp', 'dnspython', 'numpy', 'six'],
scripts = [
os.path.join('bin','lvalert_admin'),
......@@ -61,10 +61,9 @@ setup(
# Python name RHEL Name Debian name MacPort Name
# (easy_install) (yum) (apt-get) (port install)
#
# pyxmpp pyxmpp * python-pyxmpp py27-pyxmpp
# libxml2 ** libxml2-python python-libxml2 libxml2-python
# M2Crypto m2crypto python-m2crypto py27-m2crypto
# dnspython python-dns python-dnspython py27-dnspython
# pyxmpp pyxmpp * python-pyxmpp
# libxml2 ** libxml2-python python-libxml2
# dnspython python-dns python-dnspython
#
# * lscsoft package
#
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment