Merge branch 'matplotlib_3.6.0' into 'master'

Ensure compatibility with matplotlib>=3.6.0

See merge request !711
29 jobs for finalise-v0.13.9 in 91 minutes and 22 seconds (queued for 4 seconds)